SMS Status Message Viewer Does Not Work on Windows XP with Low User Permissions (816066)



The information in this article applies to:

  • Microsoft Systems Management Server 2.0 SP4

SYMPTOMS

When you are using SMS Status Message Viewer on Microsoft Windows XP, you may receive the following error message if you are logged on as a non-administrator user:
SMS 2.0 Utility - Status Message Viewer has encountered a problem and needs to close. We are sorry for the inconvenience.

The information you were working on might be lost. Microsoft Program can try to recover it for you.

Please tell Microsoft about this problem.

CAUSE

When you start SMS Status Message Viewer (Statview.exe) against an SMS Status Message query that requires a prompted Time value (for example, the System Status\Status Message Queries\All Status Messages query), Statview.exe prompts you for a time value. If you use the Specify data and time option, you are typically prompted for the date, time, and time zone for the query. If you are logged on to Windows XP as a domain user, the drop-down Time zone box is blank. If you click OK to run the Status Message, SMS Status Message Viewer generates an access violation.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Systems Management Server service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site: Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English post-SP4 HRP, ICP1, ICP4, and ICP5 versions of this fix have the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size     File name     Platform
   -------------------------------------------------------------------
   01-May-2002  20:25  2.0.1493.4193  530,032  Statview.exe  i386
   01-May-2002  20:25  2.0.1493.4193  783,120  Statview.exe  Alpha

How to Install the Hotfix

Using the Hotfix Installer

  1. Log on to the Windows XP-based workstation as a domain administrator or as a local administrator.
  2. Copy the hotfix folder structure to a local folder or to a network share.
  3. Run the hotfix installer file (Sms2.0-kb816066-sp4-x86-enu.exe) from the local folder or from the network share.
  4. Follow the instructions in the hotfix installer wizard.

Installing the Hotfix Manually

  1. Log on to the Windows XP-based workstation as a domain administrator or as a local administrator.
  2. Locate the drive and folder where the SMS Administration tools are installed.
  3. Copy the Statview.exe file from the hotfix I386 folder to the Bin\I386 folder on the local computer ("under" the main SMSAdmin folder).

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:4/14/2006
Keywords:kbQFE kbHotfixServer kbSMS200preSP6fix kbfix kbBug KB816066