FIX: Hardware-Created ASF Files Stop Playing in Media Player 9 Series (816044)



The information in this article applies to:

  • Microsoft Windows Media Player 9 Series SDK
  • Microsoft Windows Media Format 9 Series SDK
  • Microsoft Windows Media Player 9 Series for Windows 2000
  • Microsoft Windows Media Player 9 Series for Windows 98 Second Edition
  • Microsoft Windows Media Player 9 Series for Windows Millennium Edition
  • Microsoft Windows Media Player 9 Series for Windows XP

SYMPTOMS

When you try to play back certain ASF files created by hardware devices, you may receive the following error message approximately three or four minutes after playback has started:
0xC00D1199 -- Windows Media Player cannot play the file. The file is either corrupt or the Player does not support the format you are trying to play.
You may also receive this error message when you seek past the three- or four-minute mark by using the track bar.

CAUSE

When applications built on the Windows Media Format play back files, the applications make certain checks to determine if a packet is valid. The Windows Media Format incorrectly handles a case where the time wraps around because of the maximum value possible for numeric data types.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Media Update that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site: Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
The following file is available for download from the Microsoft Download Center:
DownloadDownload the wm816044 package now. For additional information about how to download Microsoft Support files, click the following article number to view the article in the Microsoft Knowledge Base:

119591 How to Obtain Microsoft Support Files from Online Services

Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help to prevent any unauthorized changes to the file.
The version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   
   Date         Time   Version     Size       File name
   ------------------------------------------------------
   04-Mar-2003  15:49  9.0.0.3001  2,058,888  Wmvcore.dll      

STATUS

Microsoft has confirmed that this is a bug in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:10/11/2005
Keywords:kbHotfixServer kbQFE kbdownload kbfix KB816044 kbAudDeveloper kbAudEndUser kbAudOEM