PRB: Duplicate Channels in IPG (815445)



The information in this article applies to:

  • Microsoft TV IPG 1.0
  • Microsoft TV IPG 1.5

SYMPTOMS

When there is a change in the channel line-up, Tribune Media Services (TMS) keeps the old channel information and adds duplicate channel IDs that contain new information.

Note After 60 days, TMS removes the duplicate channel IDs.

CAUSE

This problem occurs because IPG versions 1.0 and 1.1 do not support filtering TMS data by using a specified expiration date and a specified effective date. This causes Import Job to import all duplicate channels. Microsoft IPG 1.0 and 1.1 Server do not support duplicate channel IDs that TMS delivers.

RESOLUTION

For users of IPG 1.0 and 1.1 Server, the customer or the Microsoft deployment team can use a Custom line-up when the channel line-up changes or apply the workaround patch to the TMSLineupLoader.dll.

WORKAROUND

For IPG version 1.0 and 1.1, you can avoid using a Custom line-up by applying the patched DLL (TMSLineupLoader.dll). To do this, follow these steps:
  1. Quit all programs.
  2. Rename the TMSLineupLoader.dll file. This file is located in the MicrosoftTVInstallPath\Microsoft TV Server\Components folder. Change the name of this file to TMSLineupLoaderOriginal.dll.
  3. Copy the TMSLineupLoader.dll file from the source depot (//depot/mstv_pss/projects/IPG/kb_binaries/TMSLineupLoader/TMSLineupLoader.dll) to your MicrosoftTVInstallPath\Microsoft TV Server\Components folder.
  4. Delete all records from the line-up table in the EPG database.
  5. Run Import and Export jobs.

STATUS

Microsoft has confirmed that this is a problem in IPG version 1.0, and 1.1.
This problem was corrected in IPG 1.5 Server.

MORE INFORMATION

The TMS duplicate-channel process that is described in the "Symptoms" section is a known TMS process. Third-party products that use TMS data support this process.

Modification Type:MinorLast Reviewed:6/17/2003
Keywords:kbprb KB815445 kbAudDeveloper kbAudITPRO