Detecting digital signing issues in Windows XP (813442)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition

SYMPTOMS

You may experience one or more of the following digital signing issues on your Microsoft Windows XP-based computer:
  • When you use the System Information tool to view the signed drivers that are installed on your computer (in the System Information tool, click Software Environment, and then click Signed Drivers), none of the devices are listed as signed. An entry of either No or Not Available appears for each device in the Signed column.
  • When you try to use Microsoft Internet Explorer to visit the Microsoft Windows Update Web site (http://windowsupdate.microsoft.com), you may receive one of the following error messages:
    Software Update Incomplete

    The Windows Update software did not update successfully.

    Send error number to Microsoft (0x800B0004)

    Software Update Incomplete

    The Windows Update software did not update successfully.

    Send error number to Microsoft (0x800b0001)
  • You cannot connect to secure Web sites. When you try do so, you receive the following error message in your browser window:
    The page cannot be displayed
  • When you install new drivers or programs that use digital signatures, the following error message is written to the Setupapi.log file:
    FileName will be installed (policy=ignore).
    Error 0x800b0003: The form specified for the subject is not one supported or known by the specified trust provider.
  • When you restart the computer after you reinstall Microsoft Internet Explorer 6 by using the procedure from the following Knowledge Base article, you receive a message that says that Internet Explorer is not digitally signed:

    318378 How to reinstall or repair Internet Explorer and Outlook Express in Windows XP

  • You may not be able to sign in to Windows Messenger or MSN Explorer or MSN Explorer may time out when you retrieve your e-mail messages.
  • In the Notes box of the Sound and Display tabs of the DirectX Diagnostic Tool, you may see entries similar to the following: The file FileName is not digitally signed. This means that it has not been tested by Microsoft's Windows Hardware Quality Labs. You may be able to receive a signed driver from the manufacturer of the hardware device.
  • When you try to install Microsoft Windows XP Service Pack 1 (SP1) or later, you may receive the following error message:
    Service Pack 1 Setup could not verify the integrity of the file Update.inf. Make sure the Cryptographic service is running on this computer
  • When you try to activate Plus! DME (Digital Media Edition) over the Internet, you receive the following error message:
    Microsoft Plus! Activation was not able to activate Microsoft Plus! Digital Media Edition for the following reason:

    Microsoft Plus! Digital Media Edition cannot be activated at this time because the Microsoft Plus! Activation Wizard is unable to transmit information to the Microsoft product activation service. Verify that your computer is connected to the internet, and then try again.

CAUSE

These issues may indicate that a component of Windows XP that processes digital signatures is damaged.

RESOLUTION

To resolve this behavior, re-register the Softpub.dll, Wintrust.dll, Initpki.dll, Dssenh.dll, Rsaenh.dll, Gpkcsp.dll, Sccbase.dll, Slbcsp.dll, Mssip32.dll, and Cryptdlg.dll files. To do so, follow these steps:
  1. Click Start, and then click Run.
  2. In the Open box, type cmd, and then click OK.
  3. At the command prompt, type regsvr32 softpub.dll, and then press ENTER.
  4. Click OK when you receive the message that DllRegisterServer in Softpub.dll succeeded.
  5. Repeat steps 1 through 4 for the following files: Wintrust.dll, Initpki.dll, Dssenh.dll, Rsaenh.dll, Gpkcsp.dll, Sccbase.dll, Slbcsp.dll, Mssip32.dll, and Cryptdlg.dll.
  6. Type exit, and then press ENTER to quit Command Prompt.

Modification Type:MajorLast Reviewed:4/5/2005
Keywords:kbprb KB813442