XADM: X.400 Addresses Are Not Resolved Correctly After You Use Ldifde.exe to Import Them to Active Directory (813113)



The information in this article applies to:

  • Microsoft Exchange 2000 Server
  • Microsoft Exchange 2000 Enterprise Server

SYMPTOMS

After you use the Ldifde.exe utility to export a contact with an X.400 address, the address may not resolve correctly when you import it to Active Directory.

CAUSE

This issue may occur if the X.400 address is modified to use incorrect syntax before you import the address to Active Directory. For example, this may occur if you:
  1. Export a contact with a working X.400 address such as X400:c=US;a= ;p=Organization;o=SITE;s=last_name;g=first_name.
  2. Modify the contact to use incorrect syntax such as X400:c=US;a= ;p=Organization;s=last_name;g=first_name; o=SITE.
  3. Import the contact.
Note In this example, the correct syntax is where the organization (o=SITE) appears before the last name (s=last_name) and first name (g=first_name) of the user.

RESOLUTION

To resolve this issue, make sure that X.400 addresses use the correct syntax before you use the Ldifde.exe utility to import them.

MORE INFORMATION

For more information about the X.400 address space, see Request for Comments (RFC) 1649. To do so, visit the following RFC Web site: For additional information about how to modify an e-mail address by using Ldifde.exe, click the following article number to view the article in the Microsoft Knowledge Base:

313823 XADM: How to Modify a User's E-mail Addresses by Using Ldifde

For additional information about how to use Ldifde.exe to import and export directory objects to Active Directory, click the following article number to view the article in the Microsoft Knowledge Base:

237677 Using LDIFDE to Import and Export Directory Objects to Active Directory


Modification Type:MinorLast Reviewed:6/13/2003
Keywords:kbnofix kbBug KB813113