FIX: "Unspecified Error" Error Message When You Import or Refresh a BizDesk Catalog (811799)



The information in this article applies to:

  • Microsoft Commerce Server 2002
  • Microsoft Commerce Server 2002 SP1

SYMPTOMS

When you use Microsoft Commerce Server Business Desk (BizDesk) Catalog to import an XML file or to refresh a catalog, you may receive the following error message:
Unspecified Error
When you refresh your screen, you receive the following additional information:
Number: 80004005

Description: Unspecified Error Module: MSXML2.DLL

CAUSE

This problem occurs because the List_catalogs.asp file (located in the BizDesk Root Folder\Catalogs\Editor folder) creates a Microsoft XML (MSXML) 2.6 object.

WORKAROUND

Note To use this workaround, you must have MSXML 4.0 installed on your computer.

To work around this problem, change the following code in the List_catalogs.asp file:
CreateObject ("MSXML2.XMLHTTP.2.6)
Change all five occurrences of this code to the following:
CreateObject ("MSXML2.XMLHTTP.4.0)

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MajorLast Reviewed:8/28/2003
Keywords:kberrmsg kbfix kbbug KB811799 kbAudDeveloper kbAudITPRO