Microsoft Message Queuing cannot open local public queues unless it resolves the MQIS or Active Directory domain controller name (811033)



The information in this article applies to:

  • Microsoft Message Queuing 3.0
  • Microsoft Windows XP Professional

SYMPTOMS

If Microsoft Message Queuing cannot resolve the name of the MQIS (Message Queue Information Store) or domain controller, it fails when it tries to open public queues. Message Queuing cannot initialize in offline mode (and cannot open local public queues) if it cannot resolve the name of the MQIS or domain controller server.

CAUSE

Each Message Queuing client keeps a list of MQIS servers in the registry (either Microsoft Windows NT 4.0 primary event collectors [PECs], primary site controllers [PSCs], backup site controllers [BSCs], or Windows 2000 domain controllers). When one of the servers in the list is not responding, Message Queuing jumps to the next server. However, if the IP address of the server cannot be resolved, Message Queuing quits and stops the name resolution process.

RESOLUTION

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Windows 2000 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   04-Dec-2002  21:15  5.1.0.1035         67,200  Mqac.sys
   04-Dec-2002  21:16  5.1.0.1035         17,408  Mqbkup.exe       
   04-Dec-2002  21:47  5.1.0.1035         44,032  Mqdscli.dll      
   04-Dec-2002  21:46  5.1.0.1035        611,328  Mqqm.dll         
   04-Dec-2002  21:46  5.1.0.1035        164,864  Mqrt.dll         
   04-Dec-2002  21:46  5.1.0.1035         89,088  Mqsec.dll        
   05-Dec-2002  18:33  5.3.10.0        1,018,216  Q811033_wxp_sp2_x86_enu.exe  

				

The following information appears in the Message Queuing diagnostic log when this problem occurs:
 0x7bc> Thu Nov 14 09:28:23 2002: QM Error: cqmgr/20, HR: 0x80072af9
 0x7bc> Thu Nov 14 09:28:23 2002: QM Error: cqmgr/80, HR: 0x80072af9
 0x7bc> Thu Nov 14 09:28:23 2002: QM Error: cqmgr/130, HR: 0x80072af9
 0x7bc> Thu Nov 14 09:28:23 2002: QM Error: cqmgr/220, HR: 0x80072af9
 0x7bc> Thu Nov 14 09:28:23 2002: QM Error: qmcommnd/20, HR: 0x80072af9

Modification Type:MinorLast Reviewed:10/11/2005
Keywords:kbHotfixServer kbQFE kbbug kbfix kbWin2000preSP4Fix kbQFE KB811033 kbAudDeveloper