Spooler CPU usage remains above 50 percent if an LPR port has a DNS name that is not valid for the LPD server (810908)



The information in this article applies to:

  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Datacenter Edition
  • Microsoft Windows Server 2003, Datacenter Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows 2000 Advanced Server SP3
  • Microsoft Windows 2000 Advanced Server SP2
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Server SP3
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Professional SP3
  • Microsoft Windows 2000 Professional SP2
  • Microsoft Windows 2000 Professional SP1

SYMPTOMS

CPU usage for the Spooler service may remain above 50 percent if the LPR port name for an LPD print server cannot be resolved by using DNS. Each time that the service cannot contact the remote printer, event 2007 is logged:
Event ID: 2007
Source: LPR Print Monitor
Type: Error
Category: None
The LPR print monitor failed to open the port named port name or IP address.

CAUSE

The Spooler service tries to print to the job endlessly.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

260910 How to Obtain the Latest Windows 2000 Service Pack

Hotfix information

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Windows 2000 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows 2000 Server
   Date         Time   Version        Size     File name
   --------------------------------------------------------
   27-Nov-2002  09:17  5.0.2195.6109  124,688  Adsldp.dll
   27-Nov-2002  09:17  5.0.2195.5781  131,344  Adsldpc.dll
   27-Nov-2002  09:17  5.0.2195.6109   62,736  Adsmsext.dll
   27-Nov-2002  09:17  5.0.2195.6143  358,672  Advapi32.dll
   27-Nov-2002  09:17  5.0.2195.6094   49,936  Browser.dll
   27-Nov-2002  09:17  5.0.2195.6143  135,952  Dnsapi.dll
   27-Nov-2002  09:17  5.0.2195.6134   96,016  Dnsrslvr.dll
   27-Nov-2002  09:17  5.0.2195.6125   45,328  Eventlog.dll
   27-Nov-2002  09:17  5.0.2195.6137  147,216  Kdcsvc.dll
   22-Nov-2002  07:45  5.0.2195.6137  203,536  Kerberos.dll
   21-Aug-2002  05:27  5.0.2195.6023   71,248  Ksecdd.sys
   21-Nov-2002  06:15  5.0.2195.6136  507,664  Lsasrv.dll
   21-Nov-2002  06:15  5.0.2195.6136   33,552  Lsass.exe
   22-Nov-2002  07:20  5.0.2195.6137  109,328  Msv1_0.dll
   27-Nov-2002  09:17  5.0.2195.5979  307,472  Netapi32.dll
   27-Nov-2002  09:17  5.0.2195.6075  360,720  Netlogon.dll
   27-Nov-2002  09:17  5.0.2195.6136  921,872  Ntdsa.dll
   27-Nov-2002  09:13  5.0.2195.6143   66,832  Regsvc.exe
   27-Nov-2002  09:17  5.0.2195.6100  389,392  Samsrv.dll
   27-Nov-2002  09:17  5.0.2195.6120  130,320  Scecli.dll
   27-Nov-2002  09:17  5.0.2195.6120  303,888  Scesrv.dll
   22-Nov-2002  15:03  5.0.2195.6129  146,432  Sp3res.dll
   27-Nov-2002  09:17  5.0.2195.5859   48,912  W32time.dll
   04-Jun-2002  10:32  5.0.2195.5859   57,104  W32tm.exe
   27-Nov-2002  09:17  5.0.2195.6100  126,224  Wldap32.dll
				
Windows Server 2003
   Date         Time   Version           Size     File name      Platform
   ----------------------------------------------------------------------
   30-Nov-2004  22:17  5.2.3790.237      312,320  Localspl.dll   x86  
   30-Nov-2004  22:17  5.2.3790.220       81,920  Spoolss.dll    x86
   30-Nov-2004  22:07  5.2.3790.237      860,160  Localspl.dll   IA-64  
   30-Nov-2004  22:07  5.2.3790.220      234,496  Spoolss.dll    IA-64 

The fix for this problem creates a dialog box on the server. This dialog box indicates that the remote LPR port cannot be found and that the queue will pause. The administrator can then fix the name-resolution problem, and then click OK in the dialog box. To resume the print queue remotely, the job must be deleted; the Spooler service will try to print the next job.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Microsoft Windows 2000 Service Pack 4.

WORKAROUND

Delete LPR printers that do not have valid DNS names, or correct the DNS entries on the DNS server.

MORE INFORMATION

For additional information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the article number below to view the article in the Microsoft Knowledge Base:

265173 The Datacenter Program and Windows 2000 Datacenter Server Product

Technical support for Windows x64 editions

Your hardware manufacturer provides technical support and assistance for Microsoft Windows x64 editions. Your hardware manufacturer provides support because a Windows x64 edition was included with your hardware. Your hardware manufacturer might have customized the Windows x64 edition installation with unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with your Windows x64 edition. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about Microsoft Windows Server 2003 x64 editions, visit the following Microsoft Web site:

Modification Type:MinorLast Reviewed:10/11/2005
Keywords:kbHotfixServer kbQFE kbWin2kSP4fix kbQFE kbWin2000preSP4Fix kbfix kbbug kbPrint KB810908