Files That You Attach to a Notes Document By Using a Web Browser Are Not Returned in Search Results (810325)



The information in this article applies to:

  • Microsoft SharePoint Portal Server 2001

SYMPTOMS

When you configure a Lotus Notes database as a content source in SharePoint Portal Server, and you attach a file to a Lotus Notes document by using a Web browser, the attachment is incorrectly indexed in SharePoint Portal Server. When you search for the attachment, no results are returned.

You do not experience these symptoms when you attach a file to a Lotus Notes document by using the Lotus Notes client. When you search for a file that you attached in this way, the file appears in the search results.

CAUSE

This problem occurs because the Lotus Notes protocol handler does not recognize the file type of an attachment that you attach to a Lotus Notes document by using a Web browser. As a result, SharePoint Portal Server processes the attachment as an "unknown" file type.

RESOLUTION

This problem was first fixed in a hotfix that is now contained in a service pack. If you have installed SharePoint Portal Server 2001 Service Pack 3 or a later service pack, you do not have to apply the hotfix.

Service pack information

This problem was first corrected in SharePoint Portal Server 2001 Service Pack 3.

To resolve this problem, obtain the latest service pack for Microsoft SharePoint Portal Server 2001. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

312963 How to obtain the latest SharePoint Portal Server 2001 service pack

Hotfix information

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next SharePoint Portal Server 2001 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date         Time   Version         Size    File name
--------------------------------------------------------
25-Feb-2003  11:18  10.145.6011.9   692,224  Notesph.dll      
25-Feb-2003  10:03  10.145.6011.9    53,248  Spsqfe.exe       
26-Feb-2003  23:22                      101  Spsqfe.inf
Note Because of file dependencies, this update requires Microsoft SharePoint Portal Server 2001 Service Pack 2 (SP2) or Microsoft SharePoint Portal Server 2001 Service Pack 2a (SP2a).

STATUS

Microsoft has confirmed that this is a problem in Microsoft SharePoint Portal Server 2001.
This problem was first corrected in SharePoint Portal Server 2001 Service Pack 3.

MORE INFORMATION

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:10/5/2005
Keywords:kbSharePtPortalSvr2001SP3fix kbQFE kbfix kbbug KB810325