"Send on behalf" permission is not assigned to a user after you delegate access in Outlook (329622)
The information in this article applies to:
- Microsoft Exchange 2000 Server
This article was previously published under Q329622 Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base: 256986 Description of the Microsoft Windows registry SYMPTOMS
When you use Microsoft Outlook to try to delegate access to your mail folders to another user, the user to whom you delegate this access may not receive the "Send on behalf" permission. When you click Delivery Options on the Exchange General tab of your user account properties, the account to whom you tried to delegate access may not be listed in the Grant this permission to list under Send on behalf.
CAUSE
This problem may occur if your MAPI client program points to a global catalog server that is in a domain other than that of your user account.
Global catalogs are chosen based on the site in which the Exchange server resides. Exchange determines to which site it belongs, locates all global catalogs in the site, and then distributes them to MAPI clients to use for directory queries. However, although the global catalog contains a list of all objects in the Active Directory forest, it only contains a read-only copy of objects in other domains. In this case, this is the domain that contains your user account.
When the Name Service Provider Interface (NSPI) that MAPI uses for directory queries contacts the global catalog server in a domain other than that which contains your user account, it obtains a read-only copy of the object. When you try to change the properties of this read-only copy of the object, you are unsuccessful.
WORKAROUND
To work around this problem, use one of the following methods:
- Have an Exchange administrator grant the required "Send on behalf" access.
To do this, the administrator should follow these steps:
- Access the properties of the mailbox owner user object through the Active Directory Users and Computers
management console on an Exchange server or an Exchange System Administrator workstation.
- In the Exchange General/Delivery Options dialog box, add the delegate account to the Send on behalf list.
- Move the mailbox-enabled user to the same domain to which the Exchange 2000 Server-based computer belongs.
- Configure mailboxes to use a global catalog that is in the same domain as their own mailbox-enabled user object.
Note This method affects only those Outlook clients that connect by using MAPI.
STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
Modification Type: | Major | Last Reviewed: | 4/21/2006 |
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Keywords: | kbbug kbpending kbui KB329622 |
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