You Cannot Create New Folders When You Are Logged On as a Local Administrator (329301)



The information in this article applies to:

  • Microsoft SharePoint Portal Server 2001

This article was previously published under Q329301

SYMPTOMS

When you are logged on as a local administrator, you cannot create new subfolders. When you try to create a new folder in the Documents folder, you receive the following error message:
A folder already exist with the same name.

When you try to create a folder in a subfolder of the Documents folder, you receive the following error message:
You do not have permissions to create a sub folder or a problem with the network forbids authentication to the server.

CAUSE

This issue occurs because SharePoint Portal Server registers some event sink callbacks with the information store to implement some of its Document Management functionality.

In certain situations, the SharePoint Portal Server backup and restore process causes the SharePoint Portal Server event sink callbacks to be registered multiple times with the information store. These multiple registrations cause the information store to call the SharePoint Portal Server event sink callbacks multiple times for the same event. However, the SharePoint Portal Server callbacks should only have one event sink registered with the information store.

RESOLUTION

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next SharePoint Portal Server 2001 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date         Time   Version         Size      File name
-------------------------------------------------------
16-Sep-2002  07:37  10.145.4629.33  380,928   Pkmpi.dll
Note Because of file dependencies, this update requires Microsoft SharePoint Portal Server 2001 Service Pack 1

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:10/11/2005
Keywords:kbHotfixServer kbQFE kbQFE kberrmsg kbbug kbfix kbSharePtPortalSvr2001preSP2fix KB329301