Hyperlinks for Documents in the Document Library Point to the Shadow Folder (328969)



The information in this article applies to:

  • Microsoft SharePoint Portal Server 2001

This article was previously published under Q328969

SYMPTOMS

When you view documents in the Document Library of the Microsoft SharePoint Portal Server 2001 dashboard site, you may find that hyperlinks to published documents and checked-in unpublished documents point to the Shadow folder.

For example, if you are Author or Coordinator and you check out a previously published document, check it in, and then publish it, the Uniform Resource Locator (URL) that appears for the document is similar to the following, where ServerName is the name of the server, WorkspaceName is the name of the workspace, and DocumentName is the name of your document:

http://ServerName/WorkspaceName/SHADOW/Documents/Document Name(1.1).txt



As a result, users who use the URL to access the document may experience one or more of the following symptoms:
  • If the user who is assigned to the Reader role for the SharePoint Portal Server workspace clicks the hyperlink to open a document, the user is prompted to enter a user name and password. After they enter their credentials, they still cannot access the document.
  • The URL to the document may not reflect the latest version of the document.

CAUSE

This problem may occur in situations when different versions of the document exist in the Shadow folder. For example, when you check out a published document and then check it in, or when you check out a published document, check it in, and then publish it, the URL for the document points to the Shadow folder.

RESOLUTION

This problem was first fixed in a hotfix that is now contained in a service pack. If you have installed SharePoint Portal Server 2001 Service Pack 3 or a later service pack, you do not have to apply the hotfix.

Service pack information

This problem was first corrected in SharePoint Portal Server 2001 Service Pack 3.

To resolve this problem, obtain the latest service pack for Microsoft SharePoint Portal Server 2001. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

312963 How to obtain the latest SharePoint Portal Server 2001 service pack

Hotfix information

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next SharePoint Portal Server 2001 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The Global version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version              Size       File name
   --------------------------------------------------------
   22-Oct-2002  02:17      n/a        35,973  Folderitemspart.xsl
   22-Oct-2002  02:17      n/a        29,388  Categorybestbetitemspart.xsl
   22-Oct-2002  02:17      n/a        32,484  Categoryitemspart.xsl
   22-Oct-2002  02:17      n/a        29,250  Searchresultsbestbetspart.xsl
   22-Oct-2002  02:17      n/a        35,692  Searchresultspart.xsl
				
Note Because of file dependencies, this update requires SharePoint Portal Server 2001 Service Pack 1 (SP1).

WORKAROUND

To work around this problem, retrieve the URL for the document. To so so, right-click the Show Actions hyperlink for the document in the Document Library, and then click Properties.

The URL of the document appears next to Address: (URL).

STATUS

Microsoft has confirmed that this is a problem in Microsoft SharePoint Portal Server 2001.
This problem was first corrected in SharePoint Portal Server 2001 Service Pack 3.

Modification Type:MinorLast Reviewed:10/10/2005
Keywords:kbHotfixServer kbQFE kbSharePtPortalSvr2001SP3fix kbbug kbfix kbSharePtPortalSvr2001preSP2fix KB328969