URL In Approval Request Notifications Do Not Point to the Latest Version of the Document in SharePoint Portal Server (328967)



The information in this article applies to:

  • Microsoft SharePoint Portal Server 2001
  • Microsoft SharePoint Portal Server 2001 SP1

This article was previously published under Q328967

SYMPTOMS

When you receive a document approval notification from Microsoft SharePoint Portal Server 2001 and you click the Uniform Resource Locator (URL) that contains the display name or file name of the document in the approval request e-mail message, the latest version of the document may not appear in your browser window.

CAUSE

This problem may occur if either of the following conditions are true:
  • The document is submitted for approval more than one time, and you click a URL in a notification that is not the latest approval request message that was sent.
  • Changes are made to the document after the original approval request is sent.
As a result, an older version of the document appears in your browser window.

RESOLUTION

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next SharePoint Portal Server 2001 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The Global version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version  Size    File name
   -------------------------------------------------
   17-Sep-2002  03:22  n/a      20,998  Approval.xsl       
				
This new file generates approval notifications that contain only one link that always points to the latest version of the document that was submitted for approval.

Note Because of file dependencies, this update requires Microsoft SharePoint Portal Server 2001 Service Pack 1.

WORKAROUND

To work around this problem, click the Click here to approve or reject this document URL in the approval request notification. When you do so, the latest version of the document that is submitted for approval appears in the Document Inspection page in your browser window.

STATUS

Microsoft has confirmed that this is a problem in Microsoft SharePoint Portal Server 2001.

MORE INFORMATION

You can use an approval process in SharePoint Portal Server 2001 to review and approve documents that are contained in enhanced folders before you publish them to the dashboard site. To configure an approval process for a folder in SharePoint Portal Server 2001, follow these steps:
  1. In the SharePoint Portal Server workspace, right-click the folder where you want to configure an approval process, and then click Properties.
  2. Click the Approval tab.
  3. Make sure that the Documents must be approved before publishing check box is selected, and then click Add.
  4. In the Select Users dialog box, click the user who you want to add to the list of approvers, click Add, and then click OK.
  5. For each user you add to the list of approvers, click the user name in the Approvers box, and then click Set E-mail.
  6. Type an e-mail address for the user in the E-mail address box, and then click OK.
  7. Under Route to approvers, specify the approval route option that you want.
  8. If you want to add comments to the e-mail message, type your comments in the Comments for approval e-mail box, and then click OK.

Modification Type:MinorLast Reviewed:10/10/2005
Keywords:kbHotfixServer kbQFE kbbug kbfix kbSharePtPortalSvr2001preSP2fix KB328967