Microsoft Project Professional client cannot connect to the Microsoft Project Server (328958)



The information in this article applies to:

  • Microsoft Project Server 2002

This article was previously published under Q328958
Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

A Microsoft Project Professional client computer may not successfully connect to a Microsoft Project Server 2002-based computer that has a different language setting. For example, an English Project Professional client that is using Thai regional system settings may not connect to a Project Server 2002-based computer that is also using Thai regional system settings.

CAUSE

This problem may occur if either of the following conditions exists:
  • The Project Professional client computer is using a locale setting that is different from the locale setting of the Project Server-based computer.

    For example, if a Japanese Project Professional client with Japanese locale settings tries to connect to a Japanese Project Server computer that is using English locale settings.
  • The Project Professional client that was used to generate the Global Enterprise template is in a different language locale than the Project Server.

    For example, an English Project Professional client that is using Thai local settings cannot connect to an English Project Server-based computer that is using Thai locale settings because the Global Template was created by using English settings.

RESOLUTION

To resolve this problem, use one of the following methods.

Method 1: Change the locale setting of the Project Professional client

When you suspect that the Project Professional client computer is using a locale setting that is different from the locale setting of the Project Server-based computer, change the locale setting of the Project Professional client to match the locale setting of the server.

For information about how to identify the Codepage IDs for your locale, see the "International issues" section of the Microsoft Project Server Readme. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

323018 PRJ2002: Where to Find the Readme Files That Are Included with Microsoft Project and Microsoft Project Server



Method 2: Create a registry key to force the codepages to match

When you suspect that the Project Professional client that was used to generate the Global Enterprise template is in a different language locale than the Project Server, create a registry key to force the codepages to match.

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
To create a registry key to force the codepages to match, follow these steps:
  1. Click Start, point to Programs, point to Accessories, and then click Notepad.
  2. Type the following text in the Notepad document:
     REGEDIT4 
    [HKEY_CURRENT_USER\Software\Microsoft\Office\MS Project\Codepages]
  3. On the next blank line, repeat the registry key from step 2, at the end of the key add a backslash character (\) followed by the ID of the codepage that is used on your computer.

    The following example uses the Turkish codepage IDs:

    [HKEY_CURRENT_USER\Software\Microsoft\Office\MS Project\Codepages\1254]

  4. On the next blank line, repeat the registry key from step 2, at the end of the key add a backslash character (\) followed by the ID of the codepage that is used on the Project Server-based computer.

    In the following example, the Project Server-based computer uses the English codepage:

    [HKEY_CURRENT_USER\Software\Microsoft\Office\MS Project\Codepages\1254\1252]

  5. Save the file as Projectproid.reg.

    The contents of the example Projectproid.reg file must appear as follows:

    REGEDIT4 [HKEY_CURRENT_USER\Software\Microsoft\Office\MS Project\Codepages] [HKEY_CURRENT_USER\Software\Microsoft\Office\MS Project\Codepages\1254] [HKEY_CURRENT_USER\Software\Microsoft\Office\MS Project\Codepages\1254\1252]

  6. Double-click the Projectproid.reg file, and then wait for the process to write to the registry.
With this registry solution, the Project Professional client can connect to the server, however full functionality in Project Server is not supported in this configuration.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

MORE INFORMATION

As part of the startup process, Project Professional opens the Enterprise Global template from Microsoft Project Server. The Enterprise Global template contains shared information that is used across all clients that are connecting to Microsoft Project Server, including calendars. The shared information is localized into the language version of Project Server (for example the French version of Project Server contains a calendar localized for French). Significant problems can occur when Project Professional in one language starts using an Enterprise Global template localized in a different language. Therefore, by default, Microsoft Project Professional prevents a connection to a Project Server where the localized strings may be in conflict.

The Psread10.htm file that is included with Project Server 2002 contains a table that outlines the language versions of Project Server and Project Professional, and if they can interoperate. To open this file, follow these steps:
  1. Click Start, click Run, and then type Psread10.htm.
  2. Click OK to open the file.
For additional information about the Codepage property, visit the following Microsoft Web site.

Modification Type:MinorLast Reviewed:6/6/2005
Keywords:kbprb kbbug KB328958