"You do not have permission to change your password" error message when you try to change your password in Windows XP (328817)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP 64-Bit Edition Version 2002

This article was previously published under Q328817
Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you try to change your password after you log on to your Microsoft Windows XP-based computer for the first time, you may receive the following error message:
You do not have permission to change your password.

CAUSE

This problem may occur if all the following conditions are true:
  • Your computer is part of a Microsoft Windows 2000 domain.
  • The User must change password at first logon option is turned on for your user account.

    Note This scenario will only occur the first time that you log on to the account. After the first logon, this check box is cleared, and this condition does not have to be met. This scenario occurs when updates to Group Policy change the RestrictAnonymous setting to 2.
  • In the HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Lsa registry subkey of the Windows 2000 domain controller, the value of the RestrictAnonymous entry is set to 2.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows XP Professional

   Date         Time   Version        Size     File name
   -----------------------------------------------------------------
   22-Oct-2002  01:43  5.1.2600.104   100,352  Msv1_0.dll

Windows XP Professional Service Pack 1 (SP1)

   Date         Time   Version        Size     File name
   -----------------------------------------------------------------
   22-Oct-2002  02:01  5.1.2600.1134  100,864  Msv1_0.dll

Windows XP 64-Bit Edition

   Date         Time   Version       Size      File name    Platform
   -----------------------------------------------------------------
   22-Oct-2002  01:43  5.1.2600.104  340,480   Msv1_0.dll   IA-64
   21-Oct-2002  21:07  5.1.2600.104  100,352   Wmsv1_0.dll  x86

Windows XP 64-bit Edition Service Pack 1 (SP1)

   Date         Time   Version       Size      File name    Platform
   -----------------------------------------------------------------
   22-Oct-2002  02:01  5.1.2600.1134  340,992  Msv1_0.dll   IA-64
   22-Oct-2002  21:07  5.1.2600.1134  100,864  Wmsv1_0.dll  x86

WORKAROUND

To work around this problem, set the value of the RestrictAnonymous entry in the HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Lsa registry subkey on the Windows 2000 domain controller to either 0 (zero) or 1. To set the value, follow these steps.

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
  1. Click Start, and then click Run.
  2. In the Open box, type regedit, and then click OK.
  3. Locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Lsa

  4. In the right pane, double-click RestrictAnonymous.
  5. In the Value data box, type 0 or 1, and then click OK.
  6. Quit Registry Editor.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows XP Service Pack 2.

MORE INFORMATION

For additional information about how to use the RestrictAnonymous registry value in Windows 2000, click the following article number to view the article in the Microsoft Knowledge Base:

246261 How to use the RestrictAnonymous registry value in Windows 2000


Modification Type:MinorLast Reviewed:10/10/2005
Keywords:kbHotfixServer kbQFE kbQFE kbWinXPsp2fix kbbug kbfix kbWinXPpreSP2fix KB328817