SYMPTOMS
When you run the Sitebndy.exe tool from the Resource Kit against a computer that is running Systems Management Server (SMS) 2.0 Service Pack 4 (SP4) with the SP4 Hotfix Rollup Package installed, Sitebndy.exe may stop working. When this problem occurs, the following error message is recorded in the Smsprov.log file:
Client connected without impersonation activated, cannot retrieve group membership.
For additional information about the SP4 Hotfix Rollup Package, click the following article number to view the article in the Microsoft Knowledge Base:
323206 SMS: List of Bugs Fixed in the Systems Management Server 2.0 Service Pack 4 Hotfix Rollup Package
CAUSE
SMS and the Windows Management Instrumentation SMS providers enforce a security model. Because of this requirement, the SMS provider uses the Impersonation method. Sitebndy.exe was not compiled by using the Impersonation method. The hotfix that this article describes changes the DCOM impersonation level of Siteboun.exe (the new name for the tool) to "Impersonate." For additional information about impersonation and Sitebndy.exe, click the following article number to view the article in the Microsoft Knowledge Base:
294278 SMS: The Security Settings in the Source Code for the SDK Sample Programs Need Adjustment
RESOLUTION
A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next SMS 2.0 service pack that contains this hotfix.
To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:
Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the
Time Zone tab in the Date and Time tool in Control Panel.
Date Time Size File name Platform
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10-Sep-2002 11:39 204,800 Siteboun.exe I386
Note Because of file dependencies, the most recent hotfix or feature that contains these files may also contain additional files.