OL2002: Menu Items That the Client Extension Adds Are Not Visible (328677)
The information in this article applies to:
This article was previously published under Q328677 SYMPTOMS
If Microsoft Exchange custom Client Extension adds menu items to a message form and Microsoft Word is set as your default e-mail editor, the menus that the Client Extension adds may not be visible.
CAUSE
The internal mechanism that Outlook uses to display messages (MailItems) was intentionally changed. The new mechanism does not support modifications to menu items.
WORKAROUND
To work around this issue, do either of the following: - Do not use Word as your default e-mail editor
-or-
- Use the Outlook and Office CommandBar object models to add menu items by using the methods that are typically associated with component object model (COM) add-ins.
The internal mechanism that is used by COM add-ins is different from the mechanism that is used by client extensions. The COM add-ins internal mechanism bypasses the limitations that are described in the "Symptoms" section of this article.
NOTE: If you use a different e-mail format (Plain Text or HTML), the behavior that is described in the "Symptoms" section of this article may still occur.
For additional information, click the article number below
to view the article in the Microsoft Knowledge Base:
260216 HOWTO: Use the Outlook Object Model Within an Exchange Client Extension
STATUSThis behavior is by design.REFERENCESFor additional informationabout using Outlook CommandBars, click the article number below
to view the article in the Microsoft Knowledge Base:
201095 How to Use CommandBars in Outlook Solutions
Modification Type: | Minor | Last Reviewed: | 3/4/2004 |
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Keywords: | kbprb KB328677 |
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