XADM: E-Mail Messages Do Not Reach the Destination and Senders Receive NDRs (328671)
The information in this article applies to:
- Microsoft Exchange 2000 Server
- Microsoft Exchange 2000 Enterprise Server
This article was previously published under Q328671 SYMPTOMS
E-mail messages may not reach their destination, and senders may receive non-delivery reports (NDRs) that are similar to the following NDR:
The following recipient(s) could not be reached:
'UserName' on Date and Time
The e-mail system was unable to deliver the message, but did not report a specific reason. Check the address and try again. If it still fails, contact your system administrator. ServerName.Domain.com #5.0.0
If you increase the diagnostic logging level for MSExchangeTransport to Maximum on the Diagnostics Logging tab of the ServerName Properties dialog box in Exchange System Manager, events similar to the following are logged in the Application log of Event Viewer:
Event Type: Warning
Event Source: MSExchangeTransport
Event Category: SMTP Protocol
Event ID: 1706
Description:
EXPS is temporarily unable to provide protocol security with
"ServerName.Domain.com". "CSessionContext::OnEXPSInNegotiate" called
"HrServerNegotiateAuth" which failed with error code 0x8009030c (
i:\transmt\src\smtpsink\exps\expslib\context.cpp@1462 ).
Data:
0000: 0c 03 09 80 ...?
Event Type: Warning
Event Source: MSExchangeTransport
Event Category: Exchange Store Driver
Event ID: 327
Description:
The following call : EcSaveChangesMessage to the store failed. Error code : -1017.
MDB : da99a83e-b5e7-4004-ae54-91dafa273a5d. FID : . MID : . File : .
Event Type: Warning
Event Source: MSExchangeTransport
Event Category: Exchange Store Driver
Event ID: 327
Description:
The following call : EcDeleteMessages to the store failed. Error code : -1310. MDB : da99a83e-b5e7-4004-ae54-91dafa273a5d. FID : 1-31. MID : 1-2733. File : .
CAUSE
The Event ID 327 error codes -1017 and -1310 are converted to the following error message strings by the Error Converter utility (Error.exe):
Error -1310 (0xfffffae2) = JET_errInvalidTableId
Error -1017 (0xfffffc07) = JET_errRecordDeleted
These error codes indicate a problem where you cannot read or write correctly to the Exchange 2000 Server information stores. This problem may occur if the Exchange 2000 Server information store databases are damaged. This condition can exist if a file-level antivirus program is run on the \Exchsrvr folder and its subfolders, or on the Exchange Installable File System (ExIFS). By default, the Exchange Installable File System (ExIFS) is located on drive M. Note The Error.exe utility is located in the Support\Utils\I386 folder of the Exchange 2000 Server CD.
RESOLUTION
To resolve this behavior, dismount the mailbox store, defragment and fix the database, and then mount the store:
- Make sure that the Exchange Information Store service is running:
- Click Start, point to Settings, and then click Control Panel.
- Double-click Administrative Tools, and then double-click Services.
- Make sure that the Microsoft Exchange Information Store service is started. If the service is not started, right-click
Microsoft Exchange Information Store, and then click Start.
- Close the Services window, and then close the Administrative Tools window.
- Dismount the store:
- Click Start, point to Programs, point to Microsoft Exchange, and then click System Manager.
- Expand Servers, expand ServerName (where ServerName is the name of the server), and then expand the appropriate storage group. For example, you might expand First Storage Group.
- Right-click the information store that you want to dismount, to defragment, and to fix; and then click Dismount Store.
- Click Yes when you are prompted to continue the operation.
- Defragment the database by using the Eseutil.exe utility.
Important Make sure that you have sufficient hard disk space available to defragment the database(s). When you defragment a database file, the Eseutil.exe utility creates a copy of that database, and then replaces the original database with the new copy. For this reason, you must have sufficient space on the hard disk where the database is located.- Click Start, and then click Run.
- Type cmd, and then click OK.
- Change to the Exchsrvr\Bin folder, type eseutil /d path and name of database file (where path and name of database file is the path of the Exchange Server database file), and then press ENTER. For example, to defragment the private information store database file (C:\Exchsrvr\Mdbdata\Priv1.edb), type eseutil /d c:\exchsrvr\mdbdata\priv1.edb
at the command prompt, and then press ENTER.
Note Sometimes the database defragmentation may appear to stop responding or it may run slowly. Allow sufficient time for the process to complete. On a large database, this operation may take several hours. Do not run more than one instance of the Eseutil.exe utility at a time.
- Use the Isinteg.exe utility to check and to fix the integrity of the information store databases:
- Click Start, and then click Run.
- Type cmd, and then click OK.
- Change to the Exchsrvr\Bin folder, type isinteg -s ServerName -fix -test alltests
(where ServerName is the name of the Exchange server), and then press ENTER.
- Run the isinteg -s ServerName -fix -test alltests command repeatedly until no errors or warnings are reported, or until the number of errors or warnings that are reported does not change.
- Mount the store:
- In Exchange System Manager, right-click the store, and then click Mount Store.
- Click OK when you receive the message that the store was successfully mounted.
- Quit Exchange System Manager.
Modification Type: | Major | Last Reviewed: | 6/29/2004 |
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Keywords: | kbenv kberrmsg kbprb KB328671 kbAudITPRO |
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