XADM: Hard Recovery May End with Error -939523485 (328639)



The information in this article applies to:

  • Microsoft Exchange 2000 Server

This article was previously published under Q328639

SYMPTOMS

After a restore from online backup, a hard recovery with eseutil /cc may be unsuccessful. You receive the following error message:
Operation terminated with error -939523485 (Existing log file is not contiguous.) after 0.481 seconds.
> In the application Event Log you find the following events:


Event Type:	Information
Event Source:	ESE
Event Category:	General
Event ID:	100
Date:		8/30/2002
Time:		11:32:31 PM
User:		N/A
Computer:	ServerName
Description:
Information Store (1504) The database engine 6.00.5762.0004 started.
For more information, click http://search.support.microsoft.com/search/?adv=1.
Event Type:	Warning
Event Source:	ESE
Event Category:	Logging/Recovery
Event ID:	458
Date:		8/30/2002
Time:		11:32:31 PM
User:		N/A
Computer:	ServerName
Description:
Information Store (1504) Restore0003: The logfiles E0000003.log and E00.log are not in a valid sequence. Logfile replay cannot succeed if there are gaps in the sequence of available logfiles.
For more information, click http://search.support.microsoft.com/search/?adv=1.
Event Type:	Information
Event Source:	ESE
Event Category:	General 
Event ID:	101
Date:		8/30/2002
Time:		11:32:31 PM
User:		N/A
Computer:	ServerName
Description:
Information Store (1504) The database engine stopped.<BR/>
For more information, click http://search.support.microsoft.com/search/?adv=1.
Event Type:	Error
Event Source:	ESE BACKUP
Event Category:	Callback 
Event ID:	904
Date:		8/30/2002
Time:		11:32:31 PM
User:		N/A
Computer:	ServerName
Description:
Information Store (1504) Callback function call ErrESECBRestoreComplete ended with error 0xC8000263 Existing log file is not contiguous.
For more information, click http://search.support.microsoft.com/search/?adv=1.
				

CAUSE

This error message is logged even all log files mentioned in the Restore.env file and the log files after that are in sequence. The real cause of this error is that old log files are out of sequence with the log that is mentioned in Restore.env file. If you run eseutil /mh, you find that all required log files are available.

RESOLUTION

To resolve this issue, follow these steps:
  1. Run eseutil /cm to view the content of the Restore.env file.
  2. Record the log files' range.
  3. Remove all log files that are out of sequence with the log file range from Restore.env.

Modification Type:MajorLast Reviewed:7/17/2006
Keywords:kbprb KB328639