IIS stops responding after you apply updates (328512)



The information in this article applies to:

  • Microsoft Internet Information Services 5.0

This article was previously published under Q328512

SYMPTOMS

After you apply certain updates for Microsoft Windows 2000 on a server that is running Internet Information Services (IIS), you may see the following behavior:
  • You cannot access Web sites on the server.
  • You cannot open the Internet Services Manager (ISM) to configure IIS.
  • The World Wide Web Publishing Service has a status of "Starting" in the Services tool in Control Panel.
  • You see the following in your system log in Event Viewer:
    Event ID: 7022
    Event Source: Service Control Manager
    Description:
    The World Wide Web Publishing Service service hung on starting.

CAUSE

This may occur if you have installed third-party Internet security software. When you first install this kind of software, you configure it to recognize known services, such as IIS. The software permits these authorized services to access the Internet, but it refuses Internet access to any unknown applications, because this is typically a sign of a security breach on the server.

Certain updates, including Service Pack 3 for Windows 2000, install new versions of the core components of IIS. After you apply these updates, your security software may no longer recognize IIS as an authorized application. It will therefore deny Internet access to IIS until it is correctly configured to recognize the updated components. This may occur even if you have properly configured the software in the past to work with IIS.

RESOLUTION

To resolve this problem, start IIS after you start your security software. When you do this, the software can recognize the new IIS components:
  1. Click Start, click Settings, and then click Control Panel. Double-click the Administrative Tools folder, and then double-click Services.
  2. In the right pane, double-click IIS Admin Service. This opens the property sheet for that service. Click Startup Type, and then select Manual. Click OK.
  3. Repeat the previous step for any of the following services that you have installed on the server:
    • World Wide Web Publishing Service
    • FTP Publishing Service
    • Simple Mail Transfer Protocol (SMTP)
    • Network News Transport Protocol (NNTP)
  4. Click Start, click Shut Down, and then select Restart from the list of shutdown options. Click OK to restart the computer.
  5. When the computer restarts, log on as an administrator. Click Start, click Settings, and then click Control Panel. Double-click the Administrative Tools folder, and then double-click Services.
  6. In the right pane, right-click IIS Admin Service, and then click Start.
  7. Repeat the previous step for any of the following services that you have installed on the server:
    • World Wide Web Publishing Service
    • FTP Publishing Service
    • SMTP
    • NNTP
  8. As you start these services, your security software asks you whether you want to permit IIS to access the Internet. Make sure that you permit this access. Most security software packages also have the option to "remember" this decision the next time you start the program. If your software provides this option, select it.
  9. In the right pane, double-click IIS Admin Service. This opens the property sheet for that service. Click Startup Type, and then select Automatic. Click OK.
  10. Repeat the previous step for any of the following services that you have installed on the server:
    • World Wide Web Publishing Service
    • FTP Publishing Service
    • SMTP
    • NNTP

WORKAROUND

To work around this problem, manually start your security software after you start your system:
  1. Click Start, click Settings, and then click Control Panel. Double-click the Administrative Tools folder, and then double-click Services.
  2. In the right pane, locate and double-click the service that corresponds to your security software. Click Startup Type, and then select Manual. Click OK.
  3. Click Start, click Shut Down, and then select Restart in the list of shutdown options. Click OK to restart the computer.
  4. When the computer restarts, log on as an administrator. Click Start, click Settings, and then click Control Panel. Double-click the Administrative Tools folder, and then double-click Services.
  5. In the right pane, locate the service that corresponds to your security software, and then click Start. This starts your security software without affecting IIS. You must repeat this step whenever you restart your computer.

MORE INFORMATION

For more information about how to configure your security software, contact the vendor of the application.

For additional information about how this issue may cause the Microsoft Visual Studio IDE to stop responding, click the following article number to view the article in the Microsoft Knowledge Base:

871046 Visual Studio .NET stops responding when you create a Web application


Modification Type:MinorLast Reviewed:2/22/2005
Keywords:kbpending kbprb KB328512