Cannot Log On from a Macintosh Client After You Change Your Password (328417)



The information in this article applies to:

  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Server SP3
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Advanced Server SP2
  • Microsoft Windows 2000 Advanced Server SP3
  • Microsoft Windows 2000 Professional SP1
  • Microsoft Windows 2000 Professional SP2
  • Microsoft Windows 2000 Professional SP3

This article was previously published under Q328417

SYMPTOMS

After you change your logon password from a Macintosh client, you may be unable log on to a Windows 2000 Server-based computer that is running Services for Macintosh from a different Macintosh client.

However, you can log on successfully from a Windows-based client by using the new password. Additionally, if you change your password from a Windows-based client, you can log on successfully from the Macintosh client.

CAUSE

This problem may occur if you change your password from a Macintosh client that uses the Apple User Authentication Module (UAM), and then you try log on to the Windows 2000 Server-based computer from a Macintosh client that uses the Microsoft UAM.

In this scenario, the NT hash is not updated correctly in the Security Account Manager (SAM) database when you change your password from a Macintosh client that uses the Apple UAM.

RESOLUTION

Service Pack Information

To resolve this problem, obtain the latest service pack for Microsoft Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

260910 How to Obtain the Latest Windows 2000 Service Pack

Hotfix Information

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Windows 2000 service pack that contains this fix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The global version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Date         Time   Version        Size     File name
------------------------------------------------------
09-Sep-2002  21:17  5.0.2195.6604  154,160  Sfmsrv.sys
15-Jan-2003  16:59  5.0.2195.6655   77,584  Sfmsvc.exe


WORKAROUND

To work around this problem, install and use the Microsoft UAM on the Macintosh client. For additional information about how to do so, click the following article number to view the article in the Microsoft Knowledge Base:

101747 How to Install Microsoft Authentication on a Macintosh

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Microsoft Windows 2000 Service Pack 4.

Modification Type:MinorLast Reviewed:9/30/2005
Keywords:kbHotfixServer kbQFE kbWin2kSP4fix kbWin2000preSP4Fix kbbug kbfix kbWin2000FixNoSP kbNetwork KB328417