SMS: Windows 95 and Windows 98 Clients May Stop Unexpectedly or Stop Responding After You Install the HRP (328371)



The information in this article applies to:

  • Microsoft Systems Management Server 2.0 SP4

This article was previously published under Q328371

SYMPTOMS

After you install either the hotfix or the Systems Management Server (SMS) Hotfix Rollup Package (HRP) that is described in the following Microsoft Knowledge Base articles, client computers that are running either Microsoft Windows 95 or Microsoft Windows 98 may stop unexpectedly or may stop responding:

320797 SMS: Windows 98 Client Hangs When the Wuser32.exe SMS Remote Control Agent Starts

323206 SMS: List of Bugs Fixed in the Systems Management Server 2.0 Service Pack 4 Hotfix Rollup Package

CAUSE

The updated Coexist.dll file that is included with Q320797 and the HRP causes Windows 95-based or Windows 98-based clients on which the SMS Remote Control agent is turned on to either stop unexpectedly or stop responding.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next SMS service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix for SMS 2.0 Service Pack 4 (SP4) sites has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
  
   Date        Time   Version       Size       File name           Platform
   ------------------ -----------------------------------------------------
   01-May-2002 14:10  2.0.1493.4130    24,460  Coexist.dll         I386
   01-May-2002 14:10                       65  Compverremctrl.ini  I386
   01-May-2002 14:10  2.0.92.9        740,906  Remc16.exe          I386
   01-May-2002 14:10  2.0.92.9      1,371,357  Remctrl.exe         I386

				
NOTE: Because of file dependencies, the most recent hotfix or feature that contains these files may also contain additional files.

WORKAROUND

In the SMS Administrator console, disable Remote Tools Client Agent.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

This problem has been reported on various display drivers including Matrox MGA G100 AGP, ATI Rage PRO, and Nvidia.

To install the hotfix, use one of the following methods.

Use the Hotfix Installer

NOTE: This method is only for Intel-based computers.
  1. Create a folder in a location that is accessible to your SMS site servers.
  2. Copy the update file (Q328371.exe) and platform folders to the new folder.
    Arrange the folder structure so that the update file is located one folder above the platform folders.
  3. From each of the primary SMS site servers and secondary SMS site servers in your environment, log on to your site server by using an account that has administrator permissions.
  4. Quit SMS Administrator, if it is running.
  5. Run Q328371.exe, and then follow the instructions in the wizard.

Install the Hotfix Manually

  1. Create a folder in a location that is accessible to your SMS site servers.
  2. Copy the platform folders that contain the hotfix files to the new folder.
  3. From each of the primary SMS site servers and the secondary SMS site servers in your environment, log on to your site server by using an account that has administrator permissions.
  4. Quit SMS Administrator, if it is running.
  5. Stop all SMS services.
  6. Replace the Remc16.exe file in the Sms_root_folder\Inboxes\Clicomp.src\Remctrl\Platform folder with the version from the hotfix.
  7. Replace the Remctrl.exe file in the Sms_root_folder\Inboxes\Clicomp.src\Remctrl\Platform folder with the version from the hotfix.
  8. Replace the Compver.ini file in the Sms_root_folder\Inboxes\Clicomp.src\Remctrl folder with the Compverremctrl.ini file from the hotfix.

    NOTE: You must rename the Compverremctrl.ini file to Compver.ini.
  9. Restart all SMS services.
NOTE: The hotfix that is described in this article also resolves the problem that is documented in the following Microsoft Knowledge Base article:

320797 SMS: Windows 98 Client Hangs When the Wuser32.exe SMS Remote Control Agent Starts


Modification Type:MinorLast Reviewed:4/14/2006
Keywords:kbQFE kbHotfixServer kbbug kbfix kbsms200preSP4fix KB328371