Adding or removing a program may generate Event ID 7023 (328213)



The information in this article applies to:

  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Home Edition SP1

This article was previously published under Q328213

SYMPTOMS

When you add or remove a program by using Add/Remove Programs in Control Panel, the following event may appear in the system log:
Event Type: Error
Event Source: Service Control Manager
Event ID: 7023
Description: The Application Management Service terminated with the following error: The specified module could not be found.

CAUSE

The Application Management service is not supported in Microsoft Windows XP Home Edition, and the Appmgmt.dll file is not included with Windows XP Home Edition. However, the registry setting that disables this service is not configured correctly in Windows XP Home Edition. Therefore, the Add Program routine tries to find the Appmgmt.dll file. When the Add Program routine cannot find the Appmgmt.dll file, the entry appears in the system log.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
Note This fix may receive additional testing.

Note This fix was repackaged on March 27, 2003, with an updated Windows Service Pack Setup installer (Update.exe) that corrects the issue that is documented in Microsoft Knowledge Base article 817084. The repackaged hotfix contains the updated components that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date         Time   Version   Size     File name
-------------------------------------------------
15-Feb-2003  01:20  5.3.16.3  411,136  Update.exe

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:10/18/2005
Keywords:kbHotfixServer kbQFE kbenv kbbug kbfix kbWinXPsp1fix KB328213