PRB: Improper XSL Setting in a Web Part May Cause SharePoint Portal Server to Stop Responding (326135)



The information in this article applies to:

  • Microsoft SharePoint Portal Server 2001 SP1

This article was previously published under Q326135

SYMPTOMS

When a SharePoint Portal site has a Web part that has an improper setting, and multiple users (2n+2, where n is the number of processors) simultaneously request a page from that site, any SharePoint directory on the same computer stops responding (hangs).

CAUSE

This behavior occurs because a Web part has the advanced option Use XSL to transform the content selected, and has Get the XSL style sheet from the following link set to a URL that is located in a SharePoint Virtual Directory and does not point to an actual .xsl file.

There is no warning to prevent this advanced setting from being set this way.

RESOLUTION

To avoid this behavior, if you select Use XSL to transform the content, verify that you set a valid path to an actual .xsl file in Get the XSL style sheet from the following link.

MORE INFORMATION

Steps to Reproduce the Behavior

  1. Verify that you have SharePoint Portal Server 2001 installed.
  2. Create a new digital dashboard at http://Server Name/Workspace Name (see "References").
  3. In the digital dashboard, click the Content tab in the upper right corner.
  4. Under Web Part Catalogs, click Microsoft Web Part Gallery.
  5. Click to select Content Viewer, and then click Import (in the lower right corner).
  6. On the Content Welcome page, under "Web Parts," click Content Viewer to see the properties of the Web part.
  7. At the bottom of the page, click Show Advanced Settings.
  8. Verify that Get the XSL style sheet from the following link is selected.
  9. Type the following URL (or any URL that is in the same SharePoint Virtual Directory) in the text box:

    http://servername/workspace/documents
  10. Save the changes.
  11. Stress the Web site by making multiple (2n+2, where n is the number of processors) concurrent connections.

REFERENCES


Modification Type:MajorLast Reviewed:10/22/2002
Keywords:kbprb KB326135