XADM: Exchange Cluster Disk Recovery Does Not Re-Create the Mtadata Folder (325907)



The information in this article applies to:

  • Microsoft Exchange 2000 Server

This article was previously published under Q325907

SYMPTOMS

When you re-create or recover an Exchange cluster that was damaged in a disaster, there is no automatic process to move the Mtadata folder back to the shared disk resources that are configured for each Exchange virtual server in the cluster.

Exchange Setup re-creates the Mtadata folder under the folder that Exchange was installed in (by default, the Program Files/Exchsrvr folder). The registry (restored during a system state restoration) points to the location that was configured before the disaster (the shared_disk_resource/Exchsrvr folder).

This causes the message transfer agent (MTA) service to stop responding on a recovered cluster, which eventually causes the virtual server to stop responding because none of the nodes can access the Mtadata folder to start the MTA service.

The following error messages may be logged in the Application event log:
Event Type: Error
Event Source: Service Control Manager
Event Category: None
Event ID: 7000
Computer: server_name
Description:
The Microsoft Exchange MTA Stacks service failed to start due to the following error:
The service did not respond to the start or control request in a timely fashion.

Event Type: Error
Event Source: Service Control Manager
Event Category: None
Event ID: 7009
Computer: server_name
Description:
Timeout (30000 milliseconds) waiting for the Microsoft Exchange MTA Stacks service to connect.
If you try to bring the MTA resource online from the Cluster Administrator program, you may receive the following error message in the graphical user interface (GUI):
An error occurred attempting to add pages from the '{30C5DA98-BA0C-11D2-BC65-00C04FA32177}' extension DLL: Catastrophic Failure Error ID: -2147418113

CAUSE

This problem may occur if the Mtadata folder is not in the location that the registry value points to (on the shared drive).

RESOLUTION

To resolve this problem, examine the MTADatabase Path and MTA Run Directory registry values under the HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters key to determine the correct restoration location for the Mtadata folder. Make sure that the data is properly restored to the correct location from a backup, and then try to bring the Mtadata resource online again.

STATUS

Microsoft has confirmed that this is a problem in Microsoft Exchange 2000 Server.

Modification Type:MinorLast Reviewed:4/28/2005
Keywords:kbbug kberrmsg kbnofix KB325907