Visio2002: Error in Sg.dll and "Visio Has Encountered a Problem and Needs to Close" Error Message When You Try to Start Visio (324291)



The information in this article applies to:

  • Microsoft Visio 2002 Professional
  • Microsoft Visio 2002 Standard

This article was previously published under Q324291
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you start Microsoft Visio 2002, you may receive an error message similar to the following:
Microsoft Visio has encountered a problem and needs to close. We are sorry for the inconvenience.

We have created an error report that you can send to help us improve Microsoft Visio. We will treat this report as confidential and anonymous.

To see what data this error report contains, click here.
When you view the data in the error report, the report contains an error signature similar to the following:
App Name      App Version      Module Name   Module Version  Offset
--------------------------------------------------------------------------
visio.exe     10.0.2420.4      sg.dll        10.0.2420.4     00036e8f
				

CAUSE

This problem may occur if the Shape Gallery data access components are damaged.

RESOLUTION

To resolve this problem, install Windows Installer 2.0, update the computer to use Microsoft Data Access Components (MDAC) 2.7 RTM and Microsoft Jet 4.0 Service Pack 3 (SP3), and then remove and reinstall Visio. To do so, follow these steps, in the order in which they are presented.

Step 1: Install Windows Installer 2.0

Update the Windows Installer files to the latest version. To do so, visit one of the following Microsoft Web sites, and then download and install Windows Installer 2.0.

Note: Windows Installer 2.0 is included with Microsoft Windows XP. You do not have to perform this step if you are using Windows XP.

For Microsoft Windows 98, Microsoft Windows 98 Second Edition (SE), and Microsoft Windows Millennium Edition (Me)

Windows Installer 2.0 is available for download at the following Microsoft Web site:

For Microsoft Windows NT 4.0 and Microsoft Windows 2000

Windows Installer 2.0 is available for download at the following Microsoft Web site:

Step 2: Update MDAC Files

Update the MDAC files that are installed on the computer to MDAC 2.7 RTM - Refresh (2.70.9001.0). To download and install MDAC 2.7 RTM - Refresh (2.70.9001.0), visit the following Microsoft Web site:

Step 3: Install Microsoft Jet 4.0 Service Pack 3 (SP3)

Install Microsoft Jet 4.0 Service Pack 3 (SP3). To download and install Jet 4.0 SP3, visit the following Microsoft Web site:

Microsoft Universal Data Access - Microsoft Jet 4.0 Service Pack 3 Download Page
http://www.microsoft.com/downloads/results.aspx?productID=&freetext=JET+service+pack&DisplayLang=en

Step 4: Remove and Reinstall Visio, Install Visio 2002 SR-1

NOTE: Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.

Remove Visio

  1. Click Start, and then click Control Panel.
  2. Click Add or Remove Programs.
  3. In the Currently installed programs list, click Microsoft Visio 2002, and then click Remove.
  4. Click Yes if you are prompted to confirm the removal.
  5. Follow the on-screen instructions to remove Visio.

Reinstall Visio

  1. Insert the Visio CD into the CD-ROM or DVD-ROM drive.
  2. Run Visio Setup. Follow the on-screen instructions to install Visio.

Install Visio 2002 Service Release 1 (SR-1)

For additional informationabout how to obtain and install Visio 2002 Service Release 1 (SR-1), click the article number below to view the article in the Microsoft Knowledge Base:

310474 Visio2002: How to Obtain and Install Visio 2002 Service Release 1

310463 Visio2002: List of Issues Fixed in Visio 2002 Service Release 1 (SR-1)

Start Visio

Start Visio and verify that the issue is resolved. If the issue is resolved, you do not have to follow the remaining steps in this article.

If you receive an error message similar to the one that is described earlier in the "Symptoms" section of this article that references the Sgidx.exe file, follow these steps to turn off replication of the Shape Gallery database file (Shapegallery.mdb).
  1. WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

  2. Click Start, and then click Run.
  3. In the Open box, type regedit, and then click OK.
  4. Locate and then click one of following registry keys (as appropriate).

    To turn off system-wide copying of Shapegallery.mdb:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Visio\Shape Gallery

    To turn off copying of Shapegallery.mdb for specific users:

    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Visio\Shape Gallery

  5. On the Edit menu, point to New, and then click DWORD Value.
  6. Type Index, and then press ENTER.

    The data value for this new key is automatically set to zero (0x00000000 or 0).
  7. Quit Registry Editor.

MORE INFORMATION

For more information about Windows Installer, visit the following Microsoft Web site: For more information about the MDAC, visit the following Microsoft Web site: For additional information about how to turn off copying of the Shape Gallery database, click the following article number to view the article in the Microsoft Knowledge Base:

293284 Visio2002: How to Disable the Copying of ShapeGallery.mdb on a Terminal Server


Modification Type:MajorLast Reviewed:8/25/2006
Keywords:kberrmsg kbprb KB324291