Internet Explorer file downloads over SSL do not work with the cache control headers (323308)



The information in this article applies to:

  • Microsoft Internet Explorer 6.0, when used with:
    • the operating system: Microsoft Windows XP
    • the operating system: Microsoft Windows 2000
    • the operating system: Microsoft Windows NT 4.0
    • the operating system: Microsoft Windows 98 Second Edition
  • Microsoft Internet Explorer 5.5 SP2, when used with:
    • the operating system: Microsoft Windows 2000
    • the operating system: Microsoft Windows NT 4.0
    • the operating system: Microsoft Windows Millennium Edition
    • the operating system: Microsoft Windows 98 Second Edition
  • Microsoft Internet Explorer 5.01 SP1, when used with:
    • the operating system: Microsoft Windows 2000
    • the operating system: Microsoft Windows NT 4.0
    • the operating system: Microsoft Windows 98 Second Edition
  • Microsoft Internet Explorer 5.01 SP2, when used with:
    • the operating system: Microsoft Windows 2000
    • the operating system: Microsoft Windows NT 4.0
    • the operating system: Microsoft Windows 98 Second Edition

This article was previously published under Q323308
Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you try to open a Microsoft Office document or a PDF file by typing an HTTPS URL for the document in the Address bar of Internet Explorer 6 Service Pack 1 (SP1), you may receive the following error message:
Unable to download.

Internet Explorer was unable to open this site. The requested site is either unavailable or cannot be found. Please try again later.

CAUSE

This issue occurs if the server sends a "Cache-control:no-store" header or sends a "Cache-control:no-cache" header.

RESOLUTION

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

Important Because all of the hotfix installer packages have the same installer (Q323308.exe), you must be careful to obtain the hotfix that exactly matches your version of Internet Explorer.

Internet Explorer 5.01

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows 2000 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version       Size     File name
   ------------------------------------------------------
   06-Jun-2002  15:43  5.0.3506.600  461,072  Wininet.dll
				
To Override the no-cache directive for Internet Explorer 5.01, follow these steps:
  1. Start Registry Editor.
  2. For a per-user setting, locate the following registry key:

    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings

    For a per-computer setting, locate the following registry key:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings

  3. On the Edit menu, click Add Value, and then add the following registry values:

    "BypassSSLNoCacheCheck"=Dword:00000001

  4. Quit Registry Editor.

Internet Explorer 5.5

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Internet Explorer 5.5 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size     File name
   -------------------------------------------------------
   06-Jun-2002  13:42  5.50.4918.600  481,040  Wininet.dll
				
To override the no-cache directive for Internet Explorer 5.5 SP2, follow these steps:
  1. Start Registry Editor.
  2. For a per-user setting, locate the following registry key:

    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings

    For a per-computer setting, locate the following registry key:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings

  3. On the Edit menu, click Add Value, and then add the following registry values:

    "BypassSSLNoCacheCheck"=Dword:00000001

  4. Quit Registry Editor.

Internet Explorer 6

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size     File name
   -------------------------------------------------------
   28-May-2002  13:32  6.0.2717.2800  583,168  Wininet.dll
				
To override the no-cache directive for Internet Explorer 5.5 SP2, follow these steps:
  1. Start Registry Editor.
  2. For a per-user setting, locate the following registry key:

    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings

    For a per-computer setting, locate the following registry key:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings

  3. On the Edit menu, click Add Value, and then add the following registry values:

    "BypassSSLNoCacheCheck"=Dword:00000001

  4. Quit Registry Editor.

Internet Explorer 6 SP1

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size     File name
   -------------------------------------------------------
   23-Sep-2002  14:50  6.0.2800.1121  588,288  Wininet.dll
				
To override the no-cache directive for Internet Explorer 6 SP1 before you install MS04-004, follow these steps:
  1. Start Registry Editor.
  2. For a per-user setting, locate the following registry key:

    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings

    For a per-computer setting, locate the following registry key:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings

  3. On the Edit menu, click Add Value, and then add the following registry values:

    "SSLPragmaNoCache"=Dword:00000001

  4. Quit Registry Editor.
To override the no-cache directive for Internet Explorer 6 SP1 after you install MS04-004, follow these steps:
  1. Start Registry Editor.
  2. For a per-user setting, locate the following registry key:

    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings

    For a per-computer setting, locate the following registry key:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings

  3. On the Edit menu, click Add Value.
  4. To override the directive for HTTPS connections, add the following registry value:

    "BypassSSLNoCacheCheck"=Dword:00000001

    To override the directive for HTTP connections, add the following registry value:

    "BypassHTTPNoCacheCheck"=Dword:00000001

  5. Quit Registry Editor.

WORKAROUND

To work around this problem, use a hypertext reference (HREF) to load the document.

Note This workaround works only if the server uses the "cache-control:no-store" header.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.
For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

815313 INFO: Prevent caching when you download active documents over SSL


Modification Type:MinorLast Reviewed:10/11/2005
Keywords:kbHotfixServer kbQFE kbIE600preSP2fix kbIE550PreSP3fix kbbug kbenv kberrmsg kbfix kbIE600sp1fix KB323308