A Portal Displays Two Versions of the Same Document (323041)



The information in this article applies to:

  • Microsoft SharePoint Portal Server 2001

This article was previously published under Q323041

SYMPTOMS

Portal clients may display two versions of the same document in the SharePoint Portal Server Documents portal. Both the last published version and the last unapproved version are displayed. This problem does not occur if you view the documents through the Web folder.

CAUSE

The problem may occur if the case of the letters is different (that is, uppercase letters and lowercase letters) between "shadow" versions of the document. Because of this difference in case, a string comparison that map::find does cannot find a result. Therefore, two versions of the document are displayed in the portal.

RESOLUTION

To resolve this problem, obtain the latest service pack for Microsoft SharePoint Portal Server 2001. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

312963 How to Obtain the Latest SharePoint Portal Server 2001 Service Pack

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Version   File name
   -------------------
   4629.23   Pkmvm.dll
				
NOTE: Because of file dependencies, this update requires Microsoft SharePoint Portal Server 2001 Service Pack 1

STATUS

Microsoft has confirmed that this is a problem in Microsoft SharePoint Portal Server 2001.
This problem was first corrected in Microsoft SharePoint Portal Server 2001 Service Pack 2.

Modification Type:MinorLast Reviewed:9/27/2005
Keywords:kbHotfixServer kbQFE kbSharePtPortalSvr2001SP2fix kbbug kbfix kbSharePtPortalSvr2001preSP2fix KB323041