You receive a "Cannot open this file" error message when you try to open a publication in Publisher 2002 on a Windows XP-based or Windows 2000-based computer (322120)



The information in this article applies to:

  • Microsoft Publisher 2002, when used with:
    • the operating system: Microsoft Windows XP
    • the operating system: Microsoft Windows 2000

This article was previously published under Q322120

SYMPTOMS

When you try to open a publication, you may receive the following error message:
Cannot open this file
This problem occurs if you use a Microsoft Windows XP-based or Windows 2000-based computer and try to open a publication that was created on a Microsoft Windows 98-based computer.

CAUSE

When you save a publication, Publisher stores the printer settings with the file. Because Windows 98 uses different printer drivers than Windows XP or Windows 2000, when you try to open a publication that was created on a Windows 98-based computer in a Windows XP or Windows 2000 environment, Publisher cannot find the Windows 98 printer driver, and you receive the error message.

RESOLUTION

To resolve this problem, follow these steps:
  1. Click Start, and then click Control Panel.
  2. Double-click Administrative Tools, and then double-click Services.
  3. Click Print Spooler, and then click Stop on the Action menu.
  4. Start Publisher, and then open your publication.
  5. Switch to the Services dialog box, click Print Spooler, and then click Start on the Action menu.
  6. Close the Services dialog box.
  7. On the File menu in Publisher, click Print.

    If you receive a warning that a printer for this publication cannot be found, click OK.
  8. In the Name box, click the printer that you want, and then click OK.
  9. On the File menu, click Save.

    Publisher saves the new printer settings with the publication.

Modification Type:MinorLast Reviewed:1/10/2006
Keywords:kberrmsg kbopenfile kbtshoot kbprb KB322120