WS_FTP Pro Causes Access Violation Error Message in Explorer.exe (321231)



The information in this article applies to:

  • Microsoft Internet Explorer version 6 for Windows NT 4.0
  • Microsoft Internet Explorer version 6 for Windows 2000

This article was previously published under Q321231

SYMPTOMS

When you right-click My Computer, and then click Explorer, you may receive the following access violation error message:
Program Error

explorer.exe has generated errors and will be closed by Windows.
You will need to restart the program.

CAUSE

This issue may occur if the IpSwitch "WS_FTP Pro" version 6.7 program is installed on your computer. The access violation error message may be caused by the version of the Wsbho2k0.dll file that is included with WS_FTP Pro version 6.7. The Wsbho2k0.dll file adds hooks to access WS_FTP Pro from a Web Browser Integration. WS_FTP Pro also adds hooks for the Windows Explorer interface. During the installation of WS_FTP Pro version 6.7, you receive the following message:

Icon Placement

WS_FTP Pro has two interfaces: the original WS_FTP Pro "classic" interface and the WS_FTP Pro Explorer interface. One or both interfaces may be installed. Each has its own icon.

Because of its tight integration with Windows Explorer, the WS_FTP Pro Explorer interface requires its icon either on your desktop or in "My Computer". If you are also installing the WS_FTP Pro classic, its icon will appear in the same place.

RESOLUTION

To resolve this issue, upgrade to WS_FTP Pro version 7.5 or later. For information about how to do so, please visit any of the following Web sites: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MajorLast Reviewed:10/30/2003
Keywords:kb3rdparty kbenv kberrmsg kbprb KB321231