You experience issues when you use a Microsoft pointing device on a Windows-based computer (321122)



The information in this article applies to:

  • Microsoft IntelliMouse 1.0
  • Microsoft IntelliMouse TrackBall
  • Microsoft IntelliPoint software 1.0
  • Microsoft IntelliPoint software 1.1
  • Microsoft IntelliPoint software 2.0
  • Microsoft IntelliPoint software 2.1
  • Microsoft IntelliPoint software 2.2
  • Microsoft IntelliPoint software 3.0
  • Microsoft IntelliPoint software 3.1
  • Microsoft IntelliPoint software 3.2
  • Microsoft IntelliPoint software 4.0
  • Microsoft IntelliMouse Explorer
  • Microsoft IntelliMouse Optical
  • Microsoft Intellimouse Optical Wheel Mouse
  • Microsoft Intellimouse Trackball Explorer
  • Microsoft Intellimouse Trackball Optical
  • Microsoft IntelliMouse Explorer, version 3.0
  • Microsoft IntelliMouse with IntelliEye
  • Microsoft IntelliMouse Explorer for Bluetooth 2.0
  • Microsoft IntelliMouse Web
  • Microsoft IntelliPoint Software 5.1
  • Microsoft Optical Desktop Elite for Bluetooth 2.0
  • Microsoft Wheel Mouse
  • Microsoft Wireless Intellimouse Explorer USB
  • Microsoft Wireless Intellimouse Explorer for Bluetooth
  • Microsoft Wireless Laser Mouse 8000

This article was previously published under Q321122
Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry


Warning The steps in the "Resolution" section may turn off the internal pointing device on a laptop computer.

SYMPTOMS

When you use a Microsoft pointing device on a Microsoft Windows-based computer, you may experience one or more of the following symptoms:
  • The pointer may move erratically.
  • The pointer may not respond when you move the pointing device.
  • Nothing happens when you click a button on the pointing device.
  • The pointing device may stop working after several minutes of use.
  • Some options or tabs may be unavailable in the Mouse item in Control Panel.
  • If you connect a Microsoft Plug and Play Serial Mouse, a Microsoft EasyBall, or a Microsoft IntelliMouse to the computer, the device may not be detected by Microsoft Windows. When you run the Add New Hardware Wizard, the issue is not resolved.

CAUSE

This issue may occur if files from a previous installation of a pointing device are still on the computer.

RESOLUTION

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.
To resolve this issue, create a system restore point. Or, back up your registry, remove the software for the pointing device software, remove the associated registry keys, remove the pointing device items from the Device Manager, and then reinstall the Microsoft pointing device. To do this, follow these steps.

Create a system restore point or back up the registry

Use the appropriate method for your version of Windows.

Windows XP

  1. Press CTRL, press ESC, use the ARROW keys to locate All Programs, and then press ENTER.
  2. Use the ARROW keys to locate Accessories.
  3. Use the ARROW keys to locate System Tools.
  4. Use the ARROW keys to locate System Restore, and then press ENTER.
  5. Use the ARROW keys to locate Create a restore point, and then press ENTER.
  6. Follow the instructions that appear on the screen to complete the restore point.

Microsoft Windows 2000 or Microsoft Windows 98

  1. Click Start, click Run, type regedt32 in the Open box, and then click OK.
  2. Locate and then click the following registry key:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet

  3. On the Registry menu, click Save Key.
  4. In the File name box, type a unique name for the key.
  5. In the Save In box, click a location for the file, and then click Save.
  6. On the Registry menu, click Exit.

Remove the Microsoft IntelliPoint software or the Logitech software

  1. Press CTRL+ESC.
  2. Use the ARROW keys to locate Control Panel, and then press ENTER.
  3. In Control Panel, use the ARROW keys to locate Add or Remove Programs, and then press ENTER.
  4. Use the ARROW keys to locate any IntelliPoint or Logitech software, press TAB to locate Remove, and then press ENTER.

Remove the registry keys

  1. Press CTRL+ESC.
  2. Click Start, click Run, type regedit in the Open box, and then press ENTER.
  3. Use the ARROW keys to locate the following registry key:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96F-E325-11CE-BFC1-08002BE10318}

  4. Use the ARROW keys to locate each subkey. Each subkey has a four-digit number. In the right pane, view the DriveDesc line. If the information to the right of the DriveDesc line indicates any kind of mouse, press DELETE to remove only that subkey. When you are prompted to confirm the deletion, click Yes.
  5. Use the ARROW keys to locate the following registry key:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{745A17A0-74D3-11D0-B6FE-00A0C90F57DA}

  6. Use the ARROW keys to locate each subkey. Each subkey has a four-digit number. In the right pane, view the DriveDesc line. If the information to the right of the DriveDesc line indicates any kind of mouse, press DELETE to remove only that subkey. When you are prompted to confirm the deletion, click Yes.
  7. Use the ARROW keys to locate the following registry key:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\*pnp 0f13

  8. Use the ARROW keys to select the *pnp 0f13 file, and then press DELETE. When you are prompted to confirm the deletion, click Yes.
  9. Use the ARROW keys to locate the following registry key:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\hid#VID_045E&PID_####

    where #### is a number, such as 0009.

  10. Press DELETE. When you are prompted to confirm the deletion, click Yes.
  11. Repeat steps 10 and 11 to delete the following registry keys, if they are present on the computer:
    • VID_045E&PID_0009="Microsoft USB IntelliMouse"
    • VID_045E&PID_001E="Microsoft USB IntelliMouse Explorer"
    • VID_045E&PID_0023="Microsoft USB Trackball Optical"
    • VID_045E&PID_0024="Microsoft USB Trackball Explorer"
    • VID_045E&PID_0025="Microsoft USB IntelliMouse with IntelliEye"
    • VID_045E&PID_0029="Microsoft USB IntelliMouse Web"
    • VID_045E&PID_0039="Microsoft USB IntelliMouse Optical"
    • VID_045E&PID_0040="Microsoft USB Wheel Mouse Optical"
    • VID_045E&PID_0047="Microsoft USB IntelliMouse Explorer 3.0"
    • VID_046D&PID_C000="Logitech USB First/Pilot Mouse"
    • VID_046D&PID_C001="Logitech USB First/Pilot Mouse+"
    • VID_046D&PID_C002="Logitech USB MouseMan Wheel"
    • VID_046D&PID_C003="Logitech USB MouseMan"
    • VID_046D&PID_C004="Logitech USB WingMan Gaming Mouse"
    • VID_046D&PID_C005="Logitech USB WingMan Gaming Wheel Mouse"
    • VID_046D&PID_C00B="Logitech USB MouseMan Wheel+"
    • VID_046D&PID_C00C="Logitech USB WheelMouse"
    • VID_046D&PID_C00D="Logitech USB MouseMan Wheel+"
    • VID_046D&PID_C00E="Logitech USB Wheel Mouse"
    • VID_046D&PID_C030="Logitech USB iFeel Mouse"
    • VID_046D&PID_C031="Logitech USB iFeel Mouse+"
    • VID_046D&PID_C032="Logitech USB iFeel MouseMan"
    • VID_046D&PID_C033="Logitech USB iFeel MouseMan+"
    • VID_046D&PID_C401="Logitech USB TrackMan Marble Wheel"
    • VID_046D&PID_C402="Logitech USB Marble Mouse"
    • VID_046D&PID_C403="Logitech USB Turbo TrackMan Marble FX"
    • VID_046D&PID_C404="Logitech USB TrackMan Wheel"
    • VID_046D&PID_C501="Logitech USB Cordless Mouse"
    • VID_046D&PID_C502&MI_01&Col01="Logitech HID Cordless Mouse+"
    • VID_046D&PID_C502&MI_01&Col04="Logitech HID Cordless Mouse+"
  12. Use the ARROW keys to locate the following key:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\DeviceClasses\{378de44c-56ef-11d1-bc8c-00a0c91405dd}

  13. Press DELETE. When you are prompted to confirm the deletion, click Yes.

Remove devices from Device Manager

  1. Press CTRL+ESC, use the ARROW keys to locate Control Panel, and then press ENTER.
  2. Use the ARROW keys to locate System, and then press ENTER.
  3. Use the ARROW keys to locate the Hardware tab.
  4. Use the TAB key to locate Device Manager, and then press ENTER.
  5. Use the ARROW keys to locate Mice and Other Pointing Devices, and then press ENTER.
  6. Click any pointing device that is related to IntelliMouse or USB, and then press DELETE. When you are prompted to confirm the deletion, click Yes.
  7. Follow the instructions that appear on the screen to remove the device.
  8. Use the ARROW keys to locate Human Interface Devices, and then press ENTER.
  9. Use the ARROW keys to select any device under this heading, and then press DELETE. When you are prompted to confirm the deletion, click Yes.
  10. Repeat step 8 until you have removed all the devices.
  11. Use the ARROW keys to locate Universal Serial Bus Controllers.
  12. Use the ARROW keys to select any device that indicates Root Hub or Host Controller, and then press DELETE. When you are prompted to confirm the deletion, click Yes.
  13. Use the ARROW keys to locate Mice and Other Pointing Devices.
  14. Use the ARROW keys to select any other devices under this heading, and then press DELETE. When you are prompted to confirm the deletion, click Yes.

Reinstall the IntelliMouse pointing device

  1. Plug the IntelliMouse pointing device into the computer.
  2. Restart the computer.
  3. Follow the instructions that appear on the screen to complete the installation process.

MORE INFORMATION

For more information about pointing devices that do not work as expected, click the following article number to view the article in the Microsoft Knowledge Base:

185663 The Microsoft mouse pointer moves erratically or does not respond

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:10/6/2006
Keywords:kbenv kbHardware kbprb KB321122