Windows Media Player May Not Play Audio Files from Web Server If Third-Party Players Are Installed (320280)



The information in this article applies to:

  • Microsoft Windows Media Player 6.4
  • Microsoft Windows Media Player 7
  • Microsoft Windows Media Player 7.1
  • Microsoft Windows Media Player for Windows XP Home Edition
  • Microsoft Windows Media Player for Windows XP Professional
  • Microsoft Windows Media Player 9 Series for Windows 98 Second Edition
  • Microsoft Windows Media Player 9 Series for Windows Millennium Edition
  • Microsoft Windows Media Player 9 Series for Windows 2000
  • Microsoft Windows Media Player 9 Series for Windows XP

This article was previously published under Q320280
The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you are trying to play audio Windows Media content such as .wma, .wax, and .asx from a Web server through HTTP, Windows Media Player fails and the following error is generated:
The network connection has failed. (Error ID = 0xC00D0029)
Windows Media Player may still progressively download the file into the browser cache, but it cannot play the file from the HTTP link.

CAUSE

When third-party multimedia players assume file extension ownership of Windows Media content files, they may replace registry information that is necessary for Windows Media Player to play back those files even if Windows Media Player does not own the file extension.

RESOLUTION

Method One

Add the following registry value so that Windows Media Player can play the content types that are mentioned in the "Symptoms" section. These registry changes do not affect the performance or file extension ownership of the third-party multimedia player that owns the .wma extension.
WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
  1. Start Registry Editor (Regedt32.exe).
  2. Locate, and then click the following key in the registry:

    HKEY_CLASSES_ROOT\MIME\Database\Content Type\audio/x-ms-wma

  3. On the Edit menu, click Add Value, and then add the following registry value:

    Value name: CLSID
    Data type: REG_SZ
    Value data: {CD3AFA84-B84F-48F0-9393-7EDC34128127}

  4. Quit Registry Editor.

Method Two

Using Windows Media Player 9 Series, you can perform the same operation that is mentioned in Method One in the application itself:
  1. On the Tools menu, click Options.
  2. On the General tab, select the Connect to the Internet (overrides other commands) check box, and then click OK.

STATUS

This behavior is caused by third-party multimedia players. Contact the third-party company to determine whether there is an update to the player.

Modification Type:MinorLast Reviewed:1/16/2004
Keywords:kbDSWWMM2003Swept kbnofix kbprb KB320280 kbAudDeveloper