PRB: Reliable Messaging Receipts May Fill Retry and Suspended Queues on BizTalk Server (319452)



The information in this article applies to:

  • Microsoft BizTalk Server 2000
  • Microsoft BizTalk Server 2000 SP1
  • Microsoft BizTalk Server 2000 SP1a
  • Microsoft BizTalk Server 2000 SP2
  • Microsoft BizTalk Server 2002
  • Microsoft BizTalk Server 2002 SP1

This article was previously published under Q319452

SYMPTOMS

Multiple reliable receipts may be generated for BizTalk Framework 2.0 messages that have already been processed successfully by the BizTalk Server computer. The reliable receipts may eventually fill the Retry and Suspended queues on the BizTalk Server computer.

CAUSE

This problem can occur if the site of a business partner cannot receive any documents from a BizTalk Server computer. Because the business partner does not receive the reliable receipts, the business partner BizTalk Server computer goes through the retry cycle and resends the message. With each re-sent message that is received by the BizTalk Server computer, a reliable receipt is generated. According to the BizTalk Framework 2.0 specification, each time a message is received, a receipt is returned even if the message has already been processed. The message itself is processed only one time, but the receipt is returned each time. The assumption is that if the message is received again, the partner never received the receipt, so the receipt is sent each time to make sure that the partner removes the message from their queue.

STATUS

This behavior is by design.

Modification Type:MajorLast Reviewed:5/23/2003
Keywords:kbprb KB319452