SMS: Retrying a Package Update May Create Many Jobs (319207)
The information in this article applies to:
- Microsoft Systems Management Server 2.0
This article was previously published under Q319207 IMPORTANT: This article contains information about modifying the registry. Before you
modify the registry, make sure to back it up and make sure that you understand how to restore
the registry if a problem occurs. For information about how to back up, restore, and edit the
registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows Registry
SYMPTOMS
If Systems Management Server (SMS) Distribution Manager does not update any of the local distribution points for a package, the package-update process is retried at least once an hour. If Distribution Manager is also working on other packages, Distribution Manager retries the unsuccessful package more frequently. If this problem occurs on the central site in a large hierarchy, Distribution Manager also sends the package information to every site in the hierarchy ever time it retries the package. This can significantly increase the number of site communication jobs on the central site, and a backlog of job files may occur in the \SMS\Inboxes\Schedule.box folder.
CAUSE
The package-update process does not distinguish between updating local distribution points and sending updated package data to lower-level sites in the hierarchy. Therefore, when a package is retried but a local distribution point is repeatedly not updated, the package information is repeatedly sent to the lower-level sites.
RESOLUTIONService Pack Information To resolve this problem, obtain the latest service pack for Microsoft Systems Management Server 2.0. For additional information, click the following article number to view the article in the Microsoft Knowledge Base: 288239 How to Obtain the Latest Systems Management Server 2.0 Service Pack Hotfix InformationA supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Systems Management Server service pack that contains this hotfix. To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site: NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
The English post-Service Pack 3 version of this fix should have the following file attributes or later:
Date Time Version Size File name Platform
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1-Mar-2001 17:25 2.00.1493.3253 811,792 Baseutil.dll Alpha
1-Mar-2001 17:45 2.00.1493.3257 360,720 Distmgr.dll Alpha
1-Mar-2001 17:25 2.00.1493.3253 527,296 Baseutil.dll I386
1-Mar-2001 17:45 2.00.1493.3257 231,312 Distmgr.dll I386
NOTE: Because of file dependencies, the most recent hotfix or feature that contains the above files may also contain additional files.
WORKAROUND
You can avoid this problem if you do not have any local distribution points at the site where the package is created. This typically requires that no SMS client be directly assigned to that particular site.
If SMS Distribution Manager reports a problem in trying to reach a local distribution point, resolve the problem as soon as possible. If the distribution point has been permanently removed from the network, use the SMS Administrator console to modify the properties of any packages that still have this computer defined as a valid distribution point.
STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Microsoft Systems Management Server 2.0 Service Pack 5.
Modification Type: | Major | Last Reviewed: | 4/7/2006 |
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Keywords: | kbQFE KBHotfixServer kbSMS200preSP5fix kbbug kbfix kbPackage kbSoftwareDist KB319207 |
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