SMS package source versions may be reported incorrectly (318834)



The information in this article applies to:

  • Microsoft Systems Management Server 2003 SP2
  • Microsoft Systems Management Server 2003 SP1
  • Microsoft Systems Management Server 2.0
  • Microsoft Systems Management Server 2.0 SP1
  • Microsoft Systems Management Server 2.0 SP2
  • Microsoft Systems Management Server 2.0 SP3
  • Microsoft Systems Management Server 2.0 SP4

This article was previously published under Q318834

SYMPTOMS

The source version of a Systems Management Server (SMS) Package that appears in the SMS Administrator console at a child site may be different from the source version that appears in the parent site's SMS Administrator console view of the same child site.

In the SMS Administrator console on the child site you see the source version by clicking System Status, Package Status, Package Name, and then Child Site.

In the SMS Administrator console on the parent site you see the source version by clicking System Status, Package Status, Package Name, and then Child Site.

After the package source has been successfully updated, the two versions are the same. If they are not the same and if there are no backlogs in the status message files that are being received and processed on the parent site, the site hierarchy may be experiencing the problem that is corrected by the hotfix that is described in this article.

CAUSE

SMS status messages that are created at the child site to report the source version may be processed out of sequence when they are received at the parent site. Additionally, the current reported source version is not checked before the status message is processed. Therefore, the source version is regressed if the reported source version is earlier than the existing source version.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Systems Management Server 2.0. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

288239 How to obtain the latest Systems Management Server 2.0 service pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Systems Management Server service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.Systems Management Server 2.0, post SP3
   Date         Time   Version        Size     File name     Platform
   ------------------------------------------------------------------
   01-Mar-2001  17:20  2.0.1493.3240  810,768  Baseutil.dll  Alpha
   01-Mar-2001  17:25  2.0.1493.3241  360,720  Distmgr.dll   Alpha
   01-Mar-2001  17:20  2.0.1493.3240  526,272  Baseutil.dll  Intel
   01-Mar-2001  17:25  2.0.1493.3241  231,312  Distmgr.dll   Intel
Systems Management Server 2003, SP2If you are using an SMS 2003 SP2-based computer, install hotfix 915198. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

915198 You may receive inaccurate reports when you run SMS hardware inventory reports on the parent site server

Systems Management Server 2003, SP1
   Date         Time   Version         Size     File name
   --------------------------------------------------------
   25-Oct-2004  04:50  2.50.3174.1159  421,888  Distmgr.dll
Note Because of file dependencies, the most recent hotfix or feature that contains the above files may also contain additional files.

Hotfix installation instructions

Apply this fix on all of the sites in the SMS hierarchy. To install the fix, use one of the following methods.

Method 1: Use the hotfix installer

Note You can use this method only on I386-based computers.
  1. Copy the hotfix folder structure to a local folder on your site server or to a share on your network. The I386 and Alpha subfolders are required; you must also download them from the Microsoft FTP site. It is important to keep the folder structure intact. The Q318834.exe file is a Microsoft Windows Installer file that updates specific files on your site server.
  2. Log on to your site server by using an account with administrator permissions.
  3. On the site server, quit the SMS Administrator console.
  4. Run the Q318834.exe file and follow the instructions in the wizard. The Systems Management Server services are stopped and restarted as part of the installation process.
Method 2: Manually install the hotfix
  1. Copy the update program file (Q318834.exe) and platform folders to a new folder. The program file must be located one folder "above" the platform folders.
  2. Quit the SMS Administrator console and stop all SMS services in Control Panel. If the SMS_SITE_BACKUP service is running, stop it also.
  3. Replace the Baseutil.dll file in the SMS\Bin\Platform folder with the version located in the hotfix Platform folder
  4. Replace the Distmgr.dll file in the SMS\Bin\Platform folder with the version located in the hotfix Platform folder
  5. Restart the SMS site services.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Systems Management Server 2.0 Service Pack 5.

Modification Type:MajorLast Reviewed:7/13/2006
Keywords:kbQFE kbHotfixServer kbSMS200preSP5fix kbSoftwareDist kbbug kbfix kbsms200preSP4fix KB318834