You cannot access shared files and folders or browse computers in the workgroup (318030)



The information in this article applies to:

  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional

This article was previously published under Q318030

SYMPTOMS

On Windows XP-based computers that are configured as members of a workgroup in a peer-to-peer network environment, you may experience one or more of the following behaviors:
  • You cannot access shared folders or files.
  • You cannot locate other computers in the workgroup.
  • You receive the following error message when you double-click the workgroup in My Network Places:
    Workgroup Name is not accessible. You may not have permission to use this network resource.

CAUSE

This behavior may occur if both the following conditions are true:
  • NetBIOS over TCP/IP is not turned on (enabled) on one or more computers in the workgroup.
  • The Computer Browser service is not started or is turned off on one or more computers in the workgroup.

RESOLUTION

To resolve this issue, make sure that NetBIOS over TCP/IP is turned on and the Computer Browser service is running on each computer in the workgroup. To do this, follow these steps.

Step 1: Turn on NetBIOS over TCP/IP

  1. Click Start, click Control Panel, and then click Network and Internet Connections.
  2. Click Network Connections.
  3. Right-click Local Area Connection, and then click Properties.
  4. Click Internet Protocol (TCP/IP), and then click Properties.
  5. Click the General tab, and then click Advanced.
  6. Click the WINS tab.
  7. Under NetBIOS setting, click Enable NetBIOS over TCP/IP, and then click OK two times.
  8. Click Close to close the Local Area Connection Properties dialog box.
  9. Close the Network Connections window.

Step 2: Start the Computer Browser service

  1. Click Start, right-click My Computer, and then click Manage.
  2. Double-click Services and Applications.
  3. Double-click Services.
  4. In the right pane, right-click Computer Browser, and then click Start.
  5. Close the Computer Management window.

MORE INFORMATION

The Computer Browser service maintains an updated list of computers on the network, and it supplies this list to computers that are designated as browsers. If this service is stopped, the list is neither updated nor maintained. If this service is turned off, any services that explicitly depend on it do not start.

For additional information about the Network Setup Wizard in Windows XP, click the following article number to view the article in the Microsoft Knowledge Base:

308522 Description of the Network Setup Wizard in Windows

For additional information about how to connect to network resources in Windows XP, click the following article number to view the article in the Microsoft Knowledge Base:

311079 How to connect to network resources in Windows XP without mapping a drive or port

For additional information about file sharing in Windows XP, click the following article number to view the article in the Microsoft Knowledge Base:

304040 How to configure file sharing in Windows XP


Modification Type:MinorLast Reviewed:6/23/2005
Keywords:kbACWsurvey kberrmsg kbnetwork kbprb KB318030