Taskbar Is Missing When You Log On to Windows (318027)



The information in this article applies to:

  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional

This article was previously published under Q318027

SYMPTOMS

When you start Windows XP, you may experience one or more of the following behaviors:
  • When you log on normally, the taskbar does not appear.
  • If you press CTRL+ESC, the Start menu does not appear.
  • If you log on to Windows in Safe mode, the taskbar does appear.

CAUSE

This behavior can occur if the Windows settings for a particular user account are corrupted.

RESOLUTION

To resolve this issue, use one of the following methods.

Method 1: Troubleshoot by Starting Windows with a Minimal Set of Drivers

Try to determine whether a damaged or incompatible driver is the cause of this behavior. To do this, start Windows XP in Safe mode, and then use the clean boot troubleshooting method to determine whether a specific driver or file is causing this issue.

For additional information about how to perform clean-boot troubleshooting, click the article number%2 below to view the article%2 in the Microsoft Knowledge Base:

310353 How to Perform a Clean Boot in Windows XP

If you determine that a driver file that is loaded by a specific program is causing this issue, remove that program, and then restart Windows normally.

Method 2: Create a New User Account

Log on to the computer as Administrator, and then create a new user account. To do this, follow these steps:
  1. Restart the computer. When the Power On Self Test (POST) completes, press F8.
  2. On the Windows Advanced Options Menu, use the ARROW keys to select Safe Mode, and then press ENTER.
  3. When you are prompted to select which operating system to start, select Microsoft Windows XP edition (where edition is the edition of Windows XP that is installed), and then press ENTER.
  4. On the To begin, click your user name screen, click Administrator.
  5. Type the administrator password, and then click the arrow button.

    NOTE: In some cases, the Administrator password may be set to a blank password. In this case, do not enter a password before you click the arrow button.
  6. Click Yes to close the message that states that Windows is running in Safe mode.
  7. Click Start, right-click My Computer, and then click Manage on the shortcut menu that appears.
  8. In the Computer Management (Local) list, expand Local Users and Groups.
  9. Right-click the Users folder, and then click New User on the shortcut menu that appears.
  10. Type the user name and password in the appropriate boxes, and then retype the password in the Confirm password box.

    NOTE: If you do not want to assign a password to the user account, do not type a password in the Password or Confirm password boxes.
  11. Click to clear the User must change password at next logon check box.
  12. Click to select the Password never expires check box if you do not want the password to expire.
  13. Click Create, click Close, and then quit the Computer Management snap-in.
  14. Restart Windows normally, and then log on as the new user that you created.
  15. If the issue is resolved, reinstall the programs that you want, and then copy the documents that you want from the My Documents folder of the old user account. To copy the contents of the My Documents folder of the old user account, follow these steps:
    1. Log off Windows.
    2. Press CTRL+ALT+DELETE twice.

      The Log On to Windows dialog box appears.
    3. In the User name box, type Administrator. In the Password box, type the administrator password, and then click OK.
    4. Right-click Start, and then click Explore on the shortcut menu that appears.
    5. In the Folders tree, expand the old user account under Documents and Settings.
    6. Click user name's Documents (where user name is the name of the old user account with which you experience this issue).
    7. On the Edit menu, click Select All, and then click Copy on the Edit menu.
    8. Under Documents and Settings, expand the new user account folder.
    9. Click new user's Documents (where new user is the name of the new user account that you created).
    10. On the Edit menu, click Paste.
    11. If you are prompted to replace files or folders, click Yes to All to confirm the replacement.
    12. On the File menu, click Close.
    13. Log off Windows.

Method 3: Repair Windows XP

Perform an in-place repair of Windows XP. Start the installation of Windows XP, but select the option to repair the existing installation. This will replace all of the Windows files, while leaving the installed programs and data intact.

For additional information about how to perform an in-place repair of Windows XP, click the article number below to view the article in the Microsoft Knowledge Base:

315341 How to Perform an In-Place Upgrade (Reinstallation) of Windows XP

MORE INFORMATION

For additional information about how to restore your address book and mail folders, click the article number below to view the article in the Microsoft Knowledge Base:

188854 OLEXP: How to Back Up the Outlook Express Address Book and Mail Folders


Modification Type:MinorLast Reviewed:12/15/2003
Keywords:kbenv kbprb KB318027