"Event ID 20099" and "Event ID 7024" Error Message When the Routing and Remote Access Service Does Not Start (317158)
The information in this article applies to:
- Microsoft Windows 2000 Server
- Microsoft Windows 2000 Advanced Server
This article was previously published under Q317158 SYMPTOMS
When the Routing and Remote Access service does not start, the following entries may be written to the system log in Event Viewer, where computer name is the name of the computer on which the Routing and Remote Access service does not start:
Event ID: 20099
Source: RemoteAccess
Computer: computer name
Description:
Cannot access registry value for GlobalInfo.
Event ID: 7024
Source: Service Control Manager
Computer: computer name
Description:
The Routing and Remote Access service terminated with service-specific error 234.
CAUSE
This behavior can occur if registry entries for the Routing and Remote Access service are damaged.
RESOLUTION
To resolve this behavior, disable the Routing and Remote Access service, and then re-enable and reconfigure the Routing and Remote Access service. To do this, follow these steps.
NOTE: When you disable the Routing and Remote Access service, the current configuration for the service (including routing protocol settings, demand-dial interfaces, and registry settings) is removed. In addition, any connected clients are disconnected.
- Click Start, point to Programs, point to Administrative Tools, and then click Routing and Remote Access.
- In the console tree, right-click the computer on which you want to disable Routing and Remote Access service, and then click Disable Routing and Remote Access.
- Click Yes when you receive the following message:
You are disabling the router and removing its configuration. To re-enable the router, you will have to reconfigure it. Do you want to continue?
- Right-click the computer on which you want to enable Routing and Remote Access service, and then click Configure and Enable Routing and Remote Access.
The Routing and Remote Access Server Setup Wizard starts.
- Follow the instructions on the pages of the Routing and Remote Access Server Setup Wizard to configure the Routing and Remote Access service.
MORE INFORMATION
For more information about the Routing and Remote Access service in Windows 2000, see Routing and Remote Access Help. Click Start, point to Programs, point to Administrative Tools, and then click Routing and Remote Access. Right-click Routing and Remote Access, and then click Help.
Modification Type: | Major | Last Reviewed: | 10/21/2003 |
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Keywords: | kberrmsg kbprb KB317158 |
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