Windows XP: TCP/IP Functionality and Internet Connectivity Are Disrupted When You Uninstall McAfee Personal Firewall (316522)



The information in this article applies to:

  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional

This article was previously published under Q316522

SYMPTOMS

After you remove McAfee Personal Firewall, one or more of the following issues may occur:
  1. You cannot view Web pages.
  2. You cannot ping URL addresses.
  3. When you issue the ipconfig /renew command, you may receive the following error message:
    An error occurred while renewing interface local area connection: an operation was attempted on something that is not a socket.

CAUSE

This issue may occur if you remove McAfee Personal Firewall from your computer through the Add/Remove Programs tool in Control Panel.

RESOLUTION

To resolve this issue, follow these steps:
  1. Reinstall McAfee Personal Firewall.
  2. Use the Uninstaller tool that comes with your McAfee product to remove Personal Firewall.
  3. Restart your computer.

MORE INFORMATION

When you use the Add/Remove Programs tool in Control Panel to remove McAfee Personal Firewall, this may result in broken networking components and an incomplete removal of the product.

Note that Personal Firewall for Microsoft Windows 98 and Microsoft Windows Millennium Edition (Me) is not compatible with Microsoft Windows XP. To upgrade to the latest version of Personal Firewall, visit the following McAfee.com Web site: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

Modification Type:MinorLast Reviewed:2/24/2003
Keywords:kberrmsg kbprb ocsso KB316522