"Error 1933" when you try to install Office 2000 Professional (314812)



The information in this article applies to:

  • Microsoft Office 2000 Professional, when used with:
    • the operating system: Microsoft Windows XP

This article was previously published under Q314812

SYMPTOMS

When you try to install Microsoft Office 2000 Professional, you may receive one of the following error messages:
Error 1933 - Windows File Protection
Windows Files must be installed for your installation to proceed.
Error 1933 - Setup was unable to update protected operating system files.
You may then be instructed to insert the operating system CD, or the latest operating system service pack source media.

Note These error messages may not offer command options or disk-drive suggestions.

CAUSE

This issue may occur if Microsoft Windows system files are missing or are corrupted.

RESOLUTION

To resolve this issue, use the following methods in the order that they appear.

Method 1: Run the "sfc /scannow" command

To do this, follow these steps.

Note The sfc /scannow command makes the System File Checker tool verify all the protected file versions and add all the missing protected files to the Dllcache folder.
  1. Click Start, and then click Run.
  2. In the Open box, type sfc /scannow, and then click OK.
After the scanning process finishes, install Microsoft Office 2000 Professional.

Method 2: Disable Services

To do this, follow these steps:
  1. Click Start.
  2. Click Run.
  3. In the Run box, type msconfig, and then click OK.
  4. On the General tab, click Selective Startup.
  5. Click to clear all the check boxes that appear.
  6. Click the Services tab.
  7. Click to select the check boxes for the following services, and then click OK:
    • Windows Installer
    • System Restore Service
    • Plug and Play
  8. Restart the computer, and then install Office.

Method 3: Reinstall Windows by Using a Recovery Disk (Windows XP Home Edition Users Only)

Note This method only applies to customers who are running an original equipment manufacture (OEM) version of Microsoft Windows XP Home Edition.

If you received a Windows XP Home Edition recovery disk with your computer, contact your OEM to get help reinstalling Windows XP Home Edition by using the recovery disk.
The following method has been known to resolve this issue on some computers.

Method 4: Edit the SOURCEPATH value in the Microsoft Windows Registry

Note Before you walk the customer through this procedure, give the customer the "editing the registry" disclaimers, as follows:

Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry


Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
  1. Start Registry Editor.
  2. Locate the following registry key:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Setup

    Note Advise the customer to back up this hive.
  3. Right-click the INSTALLATION SOURCES REG_MULTI_SZ key, and then click Modify.
  4. Change the value data to indicate the folder where the "i386" folder is located (for example, C:\Windows), and then click OK.
  5. Right-click the SOURCEPATH REG_SZ key, and then click Modify.
  6. Change the value data to indicate the folder where the "i386" folder is located (for example, C:\Windows), and then click OK.
  7. Right-click the Servicepacksourcepath REG_SZ registry key, and then click Modify.
  8. Restart the computer, and then install the Office 2000 Professional Upgrade.
  9. Change the value data to indicate the folder where the "i386" folder is located (for example, C:\Windows), and then click OK.
  10. After you restart the computer, you may be instructed to insert the operating system CD, or the latest operating system service pack source media.

Modification Type:MinorLast Reviewed:1/6/2006
Keywords:kberrmsg kbprb KB314812