Error Message: The System Could Not Open the Phonebook File (312969)



The information in this article applies to:

  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Advanced Server SP2
  • Microsoft Windows 2000 Professional SP1
  • Microsoft Windows 2000 Professional SP2

This article was previously published under Q312969

SYMPTOMS

After you install a Connection Manager profile with an associated .pbk file for all users while you are logged on as administrator, a domain user may be unable to establish the connection, and the following connection status error message may be generated:
Error 621: The system could not open the phone book file.

CAUSE

This problem can occurs because the Everyone group has read-only permissions to the "Documents and Settings\All Users\Application Data\Microsoft\Network\Connections\CM" folders and the "Documents and Settings\All Users\Application Data\Microsoft\Network\Connections\Pbk\*.pbk" files. The Everyone group needs read and write permissions.

RESOLUTION

Apply the following fix and re-install the profile to change the permissions to read and write.

To resolve this problem, obtain the latest service pack for Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

260910 How to Obtain the Latest Windows 2000 Service Pack

The English version of this fix should have the following file attributes or later:
   Date         Time      Version          Size    File name
   ---------------------------------------------------------
   11-Dec-2001  16:17     7.1.2195.4757    45,328  Cmstp.exe
				

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Windows 2000 Service Pack 3.

MORE INFORMATION

For additional information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the article number below to view the article in the Microsoft Knowledge Base:

265173 The Datacenter Program and Windows 2000 Datacenter Server Product

For additional information about how to install multiple hotfixes with only one reboot, click the article number below to view the article in the Microsoft Knowledge Base:

296861 Use QChain.exe to Install Multiple Hotfixes with One Reboot

For additional information about how to install Windows 2000 and Windows 2000 hotfixes at the same time, click the article number below to view the article in the Microsoft Knowledge Base:

249149 Installing Microsoft Windows 2000 and Windows 2000 Hotfixes


Modification Type:MinorLast Reviewed:9/26/2005
Keywords:kbHotfixServer kbQFE kbbug kbenv kberrmsg kbfix kbSysAdmin kbWin2000sp3fix KB312969