BUG: BizTalk Server Receive Function Fails to Submit to Channel After You Change the Case of the Channel Name (312755)



The information in this article applies to:

  • Microsoft BizTalk Server 2000
  • Microsoft BizTalk Server 2002

This article was previously published under Q312755

SYMPTOMS

If you try to submit a document to a BizTalk Messaging Channel for processing, the BizTalk Server receive function generates one of the following error messages:
An error occurred in BizTalk Server.
Details:
------------------------------
The channel has been removed from the database. Avoid deleting objects
when documents might exist in the queues which reference these objects.

A channel with the name "CHANNELNAME" cannot be located.

-or-

The channel "CHANNELNAME" specified for receive function "receiveFunction"
has been removed from the BizTalk Messaging Management database.

CAUSE

These errors occur if you change the case of a BizTalk Channel name in the BizTalk Messaging Manager after you specify the channel in the receive function and if the Microsoft SQL Server that houses your InterchangeBTM database uses a binary sort order.

When you create a BizTalk Messaging Channel, the name of the channel is stored in the bts_channel table of the InterchangeBTM database in SQL Server. When you create a BizTalk Server receive function and select a channel, BizTalk stores the channel name that the receive function uses in the adm_ReceiveService table of the InterchangeBTM database in SQL Server.

When a BizTalk Server receive function tries to submit a document to a channel, it compares the name of the channel in the adm_ReceiveService table to the list of channels in the bts_channel table. If BizTalk Server finds a match, the receive function submits the document to the specified channel. If BizTalk Server does not find a match, you receive one of the above-mentioned error messages.

If you change the case of the channel name in Messaging Manager after you specify that channel in a receive function, and if the InterchangeBTM database uses a binary sort order, the receive function reports an error when it tries to submit a document to this channel. The receive function generates this error because the case-sensitive channel name does not match a channel name in the bts_channel table.

RESOLUTION

If you change the case of a channel name in the BizTalk Messaging Manager, make sure that you also change the case of the channel name in any BizTalk receive functions that reference that channel.

This is only necessary if the InterchangeBTM database that is used by BizTalk Server uses a binary sort order.

STATUS

Microsoft has confirmed that this is a bug in the Microsoft products that are listed at the beginning of this article.

Modification Type:MajorLast Reviewed:6/4/2003
Keywords:kbbug kbnofix KB312755