Error Message: Spoolsv.exe Has Generated Errors and Will Be Closed by Windows (312052)



The information in this article applies to:

  • Microsoft Windows 2000 Professional

This article was previously published under Q312052
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

If you open the Printers window or attempt to print from any program, you may receive one of the following error messages:
Spoolsv.exe has generated errors and will be closed by Windows.

or

Printer operation cannot continue due to lack of resources.

or

Subsystem unavailable.

CAUSE

This issue can occur if a printer driver that is installed on the computer is damaged.

RESOLUTION

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To resolve this issue, remove printers and printer drivers, and then delete the items that are under certain keys in the registry. Follow these steps:
  1. If possible, remove any printers that are listed in the Printers window.

    To remove a printer, right-click the printer in the Printers window, click Delete, and then click Yes to confirm the deletion.
  2. In the Printers window, on the File menu, click Server Properties.
  3. On the Drivers tab, remove all of the installed printer drivers.

    To remove a printer driver, click the driver, click Remove, and then click Yes to confirm.
  4. Start Registry Editor (Regedit.exe).
  5. Export the following registry keys:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print

    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Print

  6. Delete any items that are listed under the following keys (do not delete the keys themselves):

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows NT x86\Drivers\Version-2

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows NT x86\Drivers\Version-3

    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Print\Environments\Windows NT x86\Drivers\Version-2

    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Print\Environments\Windows NT x86\Drivers\Version-3

  7. Delete any non-default items that are listed under the following keys:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors

    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Print\Monitors

    The list of Default monitors includes:

    • AppleTalk Printing Devices (When Services for Macintosh is installed)
    • BJ Language Monitor
    • Local Port
    • PJL Language Monitor
    • Standard TCP/IP Port
    • USB Monitor
    • Windows NT Fax Monitor (When a Fax Modem is installed)

    For additional information about which items are not default, click the article number below to view the article in the Microsoft Knowledge Base:

    260142 How to Troubleshoot Windows Printing Problems

  8. Delete any items that are listed under the following keys:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Printers

    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Print\Printers

  9. Quit Registry Editor.
  10. Restart your computer, and then reinstall the necessary printers.

Modification Type:MajorLast Reviewed:11/5/2003
Keywords:kbenv kberrmsg kbprb kbprint KB312052