An invalid page fault occurs in module Shdocvw.dll when you open My Computer or Control Panel (311359)



The information in this article applies to:

  • Microsoft Windows 98 Second Edition
  • Microsoft Windows 98
  • Microsoft Windows 95

This article was previously published under Q311359

SYMPTOMS

When you attempt to open My Computer or Control Panel, you may receive the following error message:
Explorer caused an invalid page fault in module SHDOCVW.dll

CAUSE

This issue can occur if the Urlmon.dll file is damaged.

RESOLUTION

To resolve this issue, extract a new copy of the Urlmon.dll file from your original Windows CD (or from the Microsoft Internet Explorer CD if you have upgraded to a later version of Microsoft Internet Explorer):
  1. Insert the Windows 98 startup disk, and then restart your computer to a command prompt. Select Start computer with CD-ROM support. Note the drive letter that is assigned to your computer's CD-ROM or DVD-ROM drive.
  2. Insert the Windows 98 CD into the CD-ROM or DVD-ROM drive.
  3. At the command prompt, type c:, and then press ENTER.
  4. Type cd\windows\system, and then press ENTER.
  5. Type rename urlmon.dll urlmon.old, and then press ENTER.
  6. Type ext, and then press ENTER.
  7. When you receive the "Please enter the path to the Windows CAB files (a:)" message, type drive:\win98 where drive is the drive letter that you noted in step 1, and then press ENTER.

    NOTE:
    • If you have an OEM installation of Windows, the .cab files may also be located in the following folder:

      C:\Windows\Options\Cabs

    • If you extract from the Internet Explorer .cab files, the .cab files may also be located in the following folder:

      C:\Windows\windows update setup files

  8. When you receive the "Please enter the name(s) of the files(s) you want to extract" message, type urlmon.dll, and then press ENTER.
  9. When you receive the "Please enter the path to extract to ("Enter" for current directory)" message, type c:\windows\system, and then press ENTER.
  10. When you receive the "Is this okay? (y/n)" message, type y, and then press ENTER.

    The file is extracted.
  11. Remove the Windows 98 startup disk, and then restart the computer.

MORE INFORMATION

For more information about how to troubleshoot this error message, click the following article numbers to view the articles in the Microsoft Knowledge Base:

175930 Illegal operations or access violations when starting Windows

192926 How to perform clean-boot troubleshooting for Windows 98

For more information about how to extract Windows compressed files, click the following article number to view the article in the Microsoft Knowledge Base:

129605 How to extract original compressed Windows files


Modification Type:MajorLast Reviewed:7/7/2005
Keywords:kberrmsg kbprb KB311359