SimpleFind Cannot Query for Order Status Codes Above 64 (311238)



The information in this article applies to:

  • Microsoft Commerce Server 2000

This article was previously published under Q311238

SYMPTOMS

When you define an order status code above 64, you may not be able to query for the status code in Business Desk or by using the Commerce Server 2000 OrderGroupManager.Find and OrderGroupManager.SimpleFind application programming interface (API) functions.

CAUSE

The query methods only consider the first 7 bits of the status code as relevant.

RESOLUTION

To resolve this problem, obtain the latest service pack for Commerce Server 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

297216 INFO: How to Obtain the Latest Commerce Server 2000 Service Pack

The English version of this fix should have the following file attributes or later:
   Date         Time   Version     Size     File name
   --------------------------------------------------------
   24-Oct-2001  22:02  4.0.0.2094  217,178  Requisition.dll
				

STATUS

Microsoft has confirmed that this is a problem in Microsoft Commerce Server 2000. This problem was first corrected in Commerce Server 2000 Service Pack 2.

Modification Type:MinorLast Reviewed:9/23/2005
Keywords:kbHotfixServer kbQFE kbbug kbCommServ2000preSP2fix kbCommServ2000SP2fix kbfix KB311238