Access 97 Stops Responding When You Open a Table That Is Linked to a FoxPro File (310815)



The information in this article applies to:

  • Microsoft Access 97

This article was previously published under Q310815
Moderate: Requires basic macro, coding, and interoperability skills.

SYMPTOMS

When you attempt to open a table that is linked to a Microsoft Visual FoxPro .dbf file, Access 97 may stop responding (hang) if the following conditions are true:
  • You are running Access 97 on a computer that runs Microsoft Windows NT Workstation 4.0, Microsoft Windows NT Server 4.0, or Microsoft Windows 2000.
  • You selected a unique index when you linked the table.
  • You linked the table through an open database connectivity (ODBC) data source name (DSN) that uses the FoxPro ODBC driver.
The same table may open without an error and without hanging on a computer that runs Microsoft Windows 95 or Microsoft Windows 98.

CAUSE

This issue can occur if there are more than 8,000 records in the linked table or if there are duplicate values in the unique index that you selected when you linked the table.

RESOLUTION

To resolve the issue, use one or more of the following methods, depending on your situation:
  • If there are more than 8,000 records in the linked table, turn off the Fetch data in background option in the DSN, and then try recreating the linked table in Access 97. The new linked table should open correctly.
  • If the selected unique index contains duplicate values and you are running Windows 2000, either define a unique index on a field in FoxPro or relink the table, selecting one or more fields that do not contain duplicate values.
  • If the selected unique index contains duplicate values and you are running Windows NT 4.0, relink the table without selecting a unique index (click Cancel when you are prompted). This change will return a non-updateable recordset when you open the linked table.
To turn off the Fetch data in background option in the DSN:
  1. Click Start on the Windows taskbar, point to Settings, and then click Control Panel.
  2. In Control Panel, double-click Data Sources (ODBC).
  3. Click the DSN that you are using to link to the .dbf file, and then click Configure.
  4. In the ODBC Visual FoxPro Setup dialog box, click Options, and then click to clear the Fetch data in background check box.
  5. Click OK to close the ODBC Visual FoxPro Setup dialog box, and then click OK to apply the change.

Modification Type:MajorLast Reviewed:9/26/2003
Keywords:kbprb KB310815