Unable to View or Select Document Profile Metadata (310719)



The information in this article applies to:

  • Microsoft SharePoint Portal Server 2001

This article was previously published under Q310719

SYMPTOMS

When you attempt to edit a profile on either a SharePoint Portal Server document or folder, the Document Profile metadata informational boxes are not displayed.

CAUSE

This behavior can occur because of a corrupted SharePoint Portal Server client cache, which is used to render the metadata information much faster.

RESOLUTION

To resolve this behavior, clear the Microsoft OLE DB cache. The location of the cache depends on the operating system that you are using. The following list contains the locations for each supported operating system:

Microsoft Windows 2000

%Appdata%\Microsoft\Msdaipp\Offline

NOTE: If there is a service using OLE DB [for example, Microsoft Internet Information Service running Active Server Pages (ASP) scripts that are using OLE DB], the cache is located in the following location:

Documents and Settings\DefaultUser\Application Data\Microsoft\Msdaipp\Offline

Microsoft Windows NT 4.0

%Profiles%\username\Application Data\Microsoft\Msdaipp\Offline

Microsoft Windows 98

%Profiles%\username\Application Data\Microsoft\Msdaipp\Offline

If the computer is configured so that users do not have different profiles, the location is:

Windows\Application Data\Microsoft\Msdaipp\Offline

To clear the cache without restarting the computer:
  1. Close all applications.
  2. Open a command prompt.
  3. Click Start, and then click Shut Down.
  4. Simultaneously press CTRL+SHIFT+ALT. While you keep these keys pressed, click Cancel in the Shut Down Windows dialog box.
  5. In the command prompt window, navigate to the cache location, and remove all of the content from the Offline folder.
  6. At the command prompt, type explorer, and then press ENTER.
You can also clear the cache by performing the following steps:
  1. Restart the computer.
  2. After you restart the computer, delete the content from the Offline folder before you start any applications.

MORE INFORMATION

Application clients can use OLE DB to access data that is located on both Microsoft FrontPage and HTTP/DAV servers (such as SharePoint Portal Server). The first time the client connects to a server (for example, when you create a Web folders shortcut to a SharePoint Portal Server computer), it automatically determines the server type and which protocol to use. The OLE DB client caches the URLs it accesses, and the associated protocols.

REFERENCES

For additional information, click the article number below to view the article in the Microsoft Knowledge Base:

275517 Microsoft OLEDB Cache May Cause the SharePoint Portal Server Client Computer to Run Out of Disk Space


Modification Type:MinorLast Reviewed:4/25/2005
Keywords:kbprb KB310719