XADM: You Cannot Delete Files on a Shared Disk If Exchange Cluster Resources Have Been Deleted (309751)



The information in this article applies to:

  • Microsoft Exchange 2000 Server

This article was previously published under Q309751

SYMPTOMS

In the following scenario, you may not be able to delete files and folders:
  • On a two-node, active/active cluster with populated mailbox stores, create a full context index, and then start a full population of the index.
  • Bring both virtual servers offline, and then delete all of the Exchange resources on both virtual servers.
  • Use Microsoft Windows Explorer to try to delete files and folders in the Exchange folder.

CAUSE

This problem can occur if the Microsoft Search service is still trying to crawl the most significant bits (MSBs). If a user deletes the Exchange cluster resources and forgets to stop the crawl or Microsoft Search service on any Messaging Database (MDB), the Exchange 2000 Server files on the shared disks cannot be deleted before re-creating new Exchange resources.

WORKAROUND

To work around this problem, stop the Microsoft Search service (from Administrative tools, click Services); after you do so, you can delete the folders and files. Stopping the Microsoft Search service effectively stops the crawl and frees the sharing violation, which allows you to delete the folders and files.

You can also work around this problem by stopping the crawl before you try to delete resources.

STATUS

Microsoft has confirmed that this is a problem in Microsoft Exchange 2000 Server.

Modification Type:MinorLast Reviewed:4/25/2005
Keywords:kbbug kbnofix KB309751