XCCC: You Cannot Start NetMeeting from Instant Messaging 3.5 (309552)



The information in this article applies to:

  • Microsoft Exchange 2000 Server
  • Microsoft NetMeeting 3.01 for Windows 2000
  • Microsoft NetMeeting 3.01 for Windows 95
  • Microsoft NetMeeting 3.01 for Windows 98
  • Microsoft NetMeeting 3.01 for Windows 98 Second Edition
  • Microsoft NetMeeting 3.01 for Windows Millennium Edition
  • Microsoft NetMeeting 3.01 for Windows NT 4.0

This article was previously published under Q309552

SYMPTOMS

You may not be able to start NetMeeting from Exchange 2000 Instant Messaging.

If you use Instant Messaging to start a NetMeeting 3.01 session, the action may not work. If you click Invite in an Instant Messaging session, you should see the To Start NetMeeting 3.01 option, but instead you see a To Start option.

CAUSE

This issue occurs because of a corrupted registry setting on the client computer. When you start Instant Messaging, it goes through the registry to look for all installed Microsoft DirectX-compliant programs.

Instant Messaging clients can invite Instant Messaging contacts to start a NetMeeting session and to start other Microsoft DirectPlay programs. This is possible because NetMeeting is a DirectPlay program that is registered in the local computer's registry.

Instant Messaging references all DirectPlay programs and exposes them for invitation to other contacts. Full DirectPlay program functionality between Instant Messaging clients is contingent on the specific program.

RESOLUTION

To resolve this issue:
  1. Apply NetMeeting version 3.01 Service Pack 2 (SP2). To obtain NetMeeting 3.01 SP2, visit the following Microsoft Web site:
  2. Determine whether or not the issue has been resolved. If the issue has been resolved, you are finished. If the issue has not been resolved, go to step 3.
  3. Locate the following registry entry:

    HKEY_LOCAL_MACHINE\SOFTWARE\MICROSOFT\ACTIVE SETUP\INSTALLED COMPONENTS\{44BBA842-CC51-11CF-AAFA-00AA00B6015B}

    This registry entry contains all the settings for NetMeeting. View values such as:

    • <no name>:REG_SZ: Netmeeting3.01
    • ComponentID: REG_SZ: Netmeeting
    • Installed:REG_BINARY:01 00 00 00
    • Locale: REG_SZ:EN
    • Stubpath:REG_SZ: rundll32.exe advpack.dll LaunchINFSection C:\WINNT\INF\MSNETMTG.INF,nETmTG.Install.PerUser.NT
    • Version:REG_SZ:4,4,0,3385
    Compare the values on a client computer that works to the values on the client computer that does not work, and then make the corresponding changes in the registry on the client computer that does not work.

Modification Type:MinorLast Reviewed:4/25/2005
Keywords:kbprb KB309552