Compass Client Hangs When You Try to Select Containers to Include or Exclude (309513)



The information in this article applies to:

  • Microsoft Metadirectory Services 2.2
  • Microsoft Metadirectory Services 2.2 SP1

This article was previously published under Q309513

SYMPTOMS

When you try to select containers to include or exclude from discovery by the Active Directory Management Agent by clicking the ellipsis (...)to view the Container Selection box, the Compass client may appear to stop responding (hang).

CAUSE

If there are a large number of nested containers, the process of enumerating them and determining their status (previously included or excluded) can take a long amount of time.

RESOLUTION

To work around this problem, use either of the following methods:
  1. Specify the containers explicitly by typing their distinguished names in the user interface.
  2. Modify the exclusions template to exclude the containers.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

The problem appears to be related to the number of containers in Active Directory, how many of those containers are currently selected, and how deeply the containers are nested.

If there is a large number of containers such as organizational units, the organizational units are nested deeply, and the more deeply nested organizational units are selected for inclusion or exclusion rather than the parent organizational units that are near the top of the tree, the problem may be seen.

Modification Type:MajorLast Reviewed:5/28/2003
Keywords:kbbug kbenv kbui KB309513